Help Wizard

Step 1



Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...


Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...


Media keys no longer work


Media keys no longer work


My media keys used to work to play, pause, skip forward/backward, etc. in Spotify, and other applications when Spotify is running. Suddenly, my media keys have no effect.


A more detailed description, using numbered steps

1. Open Spotify

2. Start playing music

3. Click my "Play/Pause" media key



What I expected to happen

Music pauses, and resumes upon another click


What actually happened



My Operating System

Windows 7 (64 bit) AND Windows 8.1 (64 bit)


Do you have a Service Pack installed?

Windows 7 is Service Pack 1, Windows 8.1 has no Service Pack


My Spotify version


My internet provider and country

Service Electric, USA


Did you do a clean install of your current Windows version or did you upgrade from a previous version?

Clean installs on both


My username



Do you have any screenshots you can attach to more clearly explain your issue?


88 Replies

Thank you sooooo much

Marked as solution

Old thread but for me simply exiting (File>Exit) then reopening spotify worked. Based on the suggestions here I also exited chrome while I was restarting spotify, but I don't have any sort of media extensions installed so I'm not sure to what extent keeping chrome shut down helped. 

Its 2017 and still driving people crazy.. Such a stupid problem and simple solution, thank you (;


Marked as solution

Fix that will work for everyone! 

Go in device manager, 

select keyboard 

select the keyboard you are using 

Right-click Update Driver software 

Browse my Computer for driver software  

Let me pick from a list od device drivers on my computer 

then find the one that with the same name as the one you are currently updating and update! 


This will work to reset all preferences 



My media keys also stopped working but I'm not using itunes or google play, can you help?


I used to just hit function+> to skip a track but then all of the sudden it stopped working.


I'm on windows 10

had the same issue where my media keys wouldn't work, for me it was the Plex App in chrome, weird part about this issue, if i ran 1 spesific game the keys would work, any other game same issue only 1 game would allow me to use the controls again.



Anyone know how long it takes to get a response here?

Go into device Manger and update the keyboard software, use the browse my
computer for programs and then select the lower option out of the 2, once
you have done that it will show you a couple different software on your
computer and select the one that is appropriate probobly the last option.
That's it, enjoy

I've tried this but still no luck.

Interestingly enough I can use the wireless work keyboard to skip track but
can't use the keyboard built into my laptop? so strange...

Thanks for the advice! It didn't even cross my mind that the chrome plex extension could be what was causing the media keys not to work!

thank u myson

**bleep** YES! It was the Google Play Music extensions for me in Chrome... idk how you ever figured out that a chrome extension would interfere with controlling spotify through the media keys but it seems your solution is the only one that works 😄 Thanks!

Mostly harmless

you legend, THANK YOU!!

I LOVE you, sir/madam.


Also got isse with Media keys working in Spotify.

Got K70 LUX Corsair on windows 10.

Next song, Previous song, Mute and Volume bar works just fine, but Stop and Pause/Play dont work properly (sometimes they work for brief moment)


What I've tried:

1)Uninstall Chrome (I dint even use it at all)

2)Reinstall Spoti client

3)Refreshing drivers in devices manager (Though i dont know if i did it corectly, got 4 HID devices there in keyboard TAB)

4)Turned off WMP service


I really dont know what else to try, can anyone help with this one ?


Should also say that Plex did the same thing and hijacked the shortcut.

chrome keyboard shortcuts to chrome only fixed it for me.  this feels like a win since the latest plex web app removed my scroll wheel volume controls today!  thanks!

OHHHH MMM GGGG!!! I was having this issue and tired ALLLLL of these suggestions and nothing worked. I restarted, detached my keyboard you name it. I have a Windows Surface.

 Randomly, I realized that my Fn key was highlighed ... I pressed it, the light went off and guess what .... Volume keys worked again ....ugggg!! I feel so silly! For two days tried to fix this ... and it was a simple fix. Try that first everyone!

Suggested posts