Help Wizard

Step 1



Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...


Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...


Media keys no longer work


Media keys no longer work


My media keys used to work to play, pause, skip forward/backward, etc. in Spotify, and other applications when Spotify is running. Suddenly, my media keys have no effect.


A more detailed description, using numbered steps

1. Open Spotify

2. Start playing music

3. Click my "Play/Pause" media key



What I expected to happen

Music pauses, and resumes upon another click


What actually happened



My Operating System

Windows 7 (64 bit) AND Windows 8.1 (64 bit)


Do you have a Service Pack installed?

Windows 7 is Service Pack 1, Windows 8.1 has no Service Pack


My Spotify version


My internet provider and country

Service Electric, USA


Did you do a clean install of your current Windows version or did you upgrade from a previous version?

Clean installs on both


My username



Do you have any screenshots you can attach to more clearly explain your issue?


88 Replies

It may not be just Google Music that's the problem, but if you have anything connected to your Chrome's extentsions in terms of media button usage, go into the Extensions tab and go to keybinds. Find out what's using those specific keybinds for your system and uncheck.

thanks, this is kind of a solution.. best ive been able to come up with so far too.  but id like it to work in AND out of chrome.

Yeah, no. Don't have Google Play Music's extension. I can only use the media controls on my XPS13 (Windows 10) if the Spotify app is open in the foreground. As soon as I send it to the background or minimize, the functionality is dead again.

how do i get the media keys to work. they have never worked since I bought my keyboard

Thank you! I was so frustrated! Solved!

I have this problem when I open adobe after effects, any solution here?

Remove any extensions you may have in Chrome for managing music etc. I had an extension called Streamkeys. I don't remember when I installed that extention. Removing it solved the problem for me immediately!

I tried all of these solutions and still couldn't get my media keys to work.

If you are using Chrome; I never installed google music either, but I the extension was automatically added I think... Go to the three dots on the top right of your browser, click more tools, click extension, your app extensions will pop up and you will see Google Play music, uncheck the "enabled" box. That is what I did and it worked.

or for apple computers, just quit the Itunes app!

For people with ASUS LAPTOPS: check out the link below for a quick fix! It might be your fn hotkey settings.


SOLUTION: Go to Start and type: C:\Program Files (x86)\ASUS\ATK Package\ATK Hotkey\HControl.exe and press enter. 🙂


Hope this helps.


Marked as solution

Thank you so much. I have a Logitec g19 (first edition) and once I deleted the google play extension it worked immediately.

I did exactly what you just said but in Extentions section there was no option for the Google music player. Please help:)


Simply any tool that plays music that was installed after spotify will hijack the media controls. reinstall spotify and if that doesnt work, uninstall whatever you installed after spotify that can play media. in my case it was itunes.

there should be an option in windows to set it up but i don't care 😄

thanks man i forgot this **bleep** **bleep** 

ty man 🙂

thank you jtbrown3


There's something so satisfying about following someone's instructions and it then just works straight away!


Soon as i changed the settings from Global, to In Chrome my media keys sprung back to life!


thank you!!

You're welcome, Andrew! 🙂

Thank you!!!!  I had no idea why my media keys weren't working--and haven't for a while but was just living with it--and finally I just decided to search for the issue and found this!  Now I can control Spotify without constantly having to switch back and forth to/from it.  Thanks again!  Worked instantly.  🙂

Disabling Google Music fixed this for me too!

Suggested posts