Media keys no longer work

Solved!
Reply

Media keys no longer work

user-removed
Not applicable

Description

My media keys used to work to play, pause, skip forward/backward, etc. in Spotify, and other applications when Spotify is running. Suddenly, my media keys have no effect.

 

A more detailed description, using numbered steps

1. Open Spotify

2. Start playing music

3. Click my "Play/Pause" media key

 

  

What I expected to happen

Music pauses, and resumes upon another click

 

What actually happened

Nothing

 

My Operating System

Windows 7 (64 bit) AND Windows 8.1 (64 bit)

 

Do you have a Service Pack installed?

Windows 7 is Service Pack 1, Windows 8.1 has no Service Pack

 

My Spotify version

0.9.10.14.g578d350b

 

My internet provider and country

Service Electric, USA

 

Did you do a clean install of your current Windows version or did you upgrade from a previous version?

Clean installs on both

 

My username

snyderxc

 

Do you have any screenshots you can attach to more clearly explain your issue?

No

8 ACCEPTED SOLUTIONS
Solution!

user-removed
Not applicable

I have determined that it is an issue with Google Music taking over the media keys when installed as a Chrome App. This thread can be closed, and marked solved.

 

SnyderXC

View solution in original post

Solution!

aachterhof
Visitor

Finally, it was driving me crazy having to switch to the screen to change songs or pause, thanks!

 

For people that maybe can't find how to do it:

 

"settings" in the chrome browser

Click "Extensions" on the left

search for "google play music" app in the list and either uncheck to disable the app or just delete

View solution in original post

Solution!

jtbrown3
Regular

See also this fix: "Chrome Hijacking Your Media Keys? Here’s The Simple Fix"

http://www.omgchrome.com/chrome-google-music-media-keys/

 

This way you can still keep the Google Play Music Chrome app loaded with no interference 🙂

View solution in original post

Solution!

skexxgo
Newbie

In my case was the Plex extension, so it can happen with other media related programs, be aware.

View solution in original post

Solution!

Vanterax
Roadie

Regardless of what extensions you have, you can change it by going into the Extensions setting of Chrome, scroll to the very botton and select "Keyboard shortcuts".

There you can enforce that whoever has control of the media keys, that it is in Chrome only and not globally.  I set my Plex extension to be in Chrome only and it solved the issue.

 

View solution in original post

Solution!

oasis01
Newbie

Old thread but for me simply exiting (File>Exit) then reopening spotify worked. Based on the suggestions here I also exited chrome while I was restarting spotify, but I don't have any sort of media extensions installed so I'm not sure to what extent keeping chrome shut down helped. 

View solution in original post

Solution!

dang1357
Casual Listener

Fix that will work for everyone! 

Go in device manager, 

select keyboard 

select the keyboard you are using 

Right-click Update Driver software 

Browse my Computer for driver software  

Let me pick from a list od device drivers on my computer 

then find the one that with the same name as the one you are currently updating and update! 

 

This will work to reset all preferences 

View solution in original post

Solution!

zer0relm
Newbie

Thank you so much. I have a Logitec g19 (first edition) and once I deleted the google play extension it worked immediately.

View solution in original post

88 Replies

bazsi44
Newbie
Thanks!

WAYLIFE
Casual Listener

THANK YOUUOOUOUOUUO!!!

FrankieQc
Newbie
Well, I was sure I had a problem with my keyboard but you sir helped me a lot today ! Thanks !

gorillacowman
Newbie

I had the same problem but the extension was plex. 

 

To find the extension that is using the keys go to the extension scroll to the end and select Keyboard shortcuts. Then look to see if any of the extensoins use themedia keys. If you find change it from global to in chrome.

jdairola
Casual Listener

The thing that is strange about this is that it must be a Spotify issue, or perhaps just a random bug with Google play because my Amazon music player app still worked with my media keys when Spotify did not. Never the less this solved the problem, thanks for the help.

Solution!

jtbrown3
Regular

See also this fix: "Chrome Hijacking Your Media Keys? Here’s The Simple Fix"

http://www.omgchrome.com/chrome-google-music-media-keys/

 

This way you can still keep the Google Play Music Chrome app loaded with no interference 🙂

View solution in original post

nmosly
Newbie

This is the best solution. Thanks!

andrew_dungan
Newbie

thank you jtbrown3

 

There's something so satisfying about following someone's instructions and it then just works straight away!

 

Soon as i changed the settings from Global, to In Chrome my media keys sprung back to life!

 

thank you!!

jtbrown3
Regular

You're welcome, Andrew! 🙂

oggeni
Regular

Should also say that Plex did the same thing and hijacked the shortcut.

Fiskaa91
Casual Listener

I LOVE you, sir/madam.

dsjenson
Visitor

THANK YOU!

DJLad97
Casual Listener

OMFG!!!!! I FREAKING LOVE YOU! THANKS SOOOOOOOOO MUCH!! 😄

user-removed
Not applicable

You're welcome 😄

valis2030
Visitor

Thank you for this solution! After messing with drivers, windows services, etc. for far too long I finally found this. Simple as can be.

 

Confirmed as a fix in my case on Windows 8.1. The offending Chrome extension was Google Play v1.232.0.

Solution!

aachterhof
Visitor

Finally, it was driving me crazy having to switch to the screen to change songs or pause, thanks!

 

For people that maybe can't find how to do it:

 

"settings" in the chrome browser

Click "Extensions" on the left

search for "google play music" app in the list and either uncheck to disable the app or just delete

View solution in original post

psturla
Newbie

Thank you very much, it worked perfectly after that.

iceflare
Newbie

Holy cow thank you! I know this thread is old but I've had this problem with not only Spotify but other platforms including VLC Media Player, Youtube, etc. God bless and have a good day 😃

castilla
Newbie

Thanks! Worked in 2018!

nwo2026
Newbie

thanks man i forgot this **bleep** **bleep** 

iqra94
Newbie

I did exactly what you just said but in Extentions section there was no option for the Google music player. Please help:)

 

SUGGESTED POSTS