Announcements

Only one channel of audio is playing (desktop and iOS)

Solved!

Only one channel of audio is playing (desktop and iOS)

kevin_kancer

Don't know why, but just one audio channel is playing on both my desktop and iOS app. Any solutions?

Reply

Accepted Solutions
Marked as solution

bbt
Hi - it ended up being the lead. I had to buy a new stereo lead and it was all Ok after that.

View solution in original post

13 Replies

blake

@kevin_kancer wrote:

Don't know why, but just one audio channel is playing on both my desktop and iOS app. Any solutions?


Hi, sorry to hear that. Before we begin troubleshooting, can we confirm that the problem is isolated to Spotify? Have you tested audio from other sources (YouTube, etc.) on both of your devices?

Peter__
If you mean only one speaker on your iPhone, mine does that too for some reason. Desktop is fine though.

Peter
Spotify Community Mentor and Troubleshooter

Spotify Last.FM Twitter LinkedIn Meet Peter Rock Star Jam 2014


If this post was helpful, please add kudos below!

Fathom

Mine is doing the exact same thing on both my desktop and laptop. All other music services play fine. It is only Spotify that does this. I have played with settings and still can not get both channels of audio to play. It's as if one rca cable was connected and the other was not. VERY annoying!!!! After a quick search of google MANY spotify users are having this problem with only one channel of audio coming through.

 

Agneum

Still an issue...

Other headphones, other sources/programs work just fine. On Spotify's app the sound is extremely shifted towards the right channel. You can still hear music playing from the left ear, although it's very weak. 

 

I've had the Spotify app working fine just a few weeks ago, but something (I still don't know what) caused it to "rip" and ever since I haven't been able to fix it. 

 

Using an Asus Xonar DX sound card

Jason

Hey @Agneuw

 

Thanks for posting in the Spotify Community.

 

That doesn't sound right. Which device and version of Spotify are you using here? Has this started happening since a particular update or change on the device?

 

Simple, but does a quick restart of the device help out? If not, try a clean reinstall of the app. This should make sure everything is installed correctly.

 

Let me know how these checks etc. help.

 

Jason.

bbt

Hi - I also have the same problem with only one side playing. I note that it is mainly 60s songs that this happens t - e.g. Summer In The City by The Loving Spoonful, Light My Fire By The Doors etc. Not all songs from that era, just some.

psinatra221
Always one channel with Spotify. What am I paying for? Half the music. This has been a long term problem Spotify is not addressing

jahnivar71

Is this case solved ? Have a customer with the same problem on iPhone 7+

wbinns

I'm having the same issue.  Faint, muffled sound on one track.  Often only the harmonies and instruments with faint lead vocals.  Have tried several suggested solutions from the Spotify Community with no luck.  Also, Spotify is very slow to load on start-up

Marked as solution

bbt
Hi - it ended up being the lead. I had to buy a new stereo lead and it was all Ok after that.

SaLock

I´m having the same problem when playing from my iphone.  Please help!

charthegnar

My issue was mainly with my desktop app (I run a mac).  Other music services and videos worked just fine, but with spotify, sound was only coming from my right speaker (I have a 2.1 setup - Audioengine 2+ with a Boston Competition Subwoofer).   I used appzapper to completely remove all spotify files (plist, preferences, etc), deleted it, emptied the trash can and redownloaded spotify.  After a clean reinstall, my problem was solved.  Hope this helps someone. 

drewhinkle

my wife's iPhone 7+ has this problem.  at first Spotify app played fine through both phone speakers but later stopped playing through left channel.  I replaced the phone and it worked fine but within a month it started having the same problem again.  all other apps play through both channels.  eliminating the phone and app seems to have isolated the problem to the Spotify app.  Perhaps there is an iOS conflict?  

Suggested posts

Env: prod