Podcasts disappearing from "Your Library" menu

Solved!
Reply
Highlighted

Podcasts disappearing from "Your Library" menu

Casual Listener

Plan

Premium

Country

 Australia

Device

ASUS VivoBook Pro17

Operating System

Windows 10

 

My Question or Issue

 I enjoy listening to a wide range of podcasts and enjoy using Spotify as my primary podcast platform, due to the ease of using Spotify Connect to stream and listen on my Yamaha receiver.

 

Recently, I've noticed the Podcasts item on the "Your Library" menu (desktop app) keeps disappearing. This means I have to manually search for favoured podcasts as without this menu item, there doesn't seem to be any other method of easily finding my list of followed podcasts.

 

I have tried removing the Spotify app and re-installing it twice now. After every re-install, the podcast link reappers in the menu but when I close Spotify, it is no longer visible when I re-open the app.

 

I've noticed on my Android phone, the Podcast menu item is a constant feature and isn't subject to this problem. As I suffer from poor eyesight, I would prefer however, to use the desktop interface in preference to the phone.

 

Any suggestions on correcting this issue?

Thanks in advance.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Solution!

Re: Podcasts disappearing from "Your Library" menu

Casual Listener

Problem resolved with the latest update.

Thanks to Spotify for fixing it and thanks to everyone who replied to my original post with your kind comments and support.

 

Happy podcast listening!

View solution in original post

21 Replies
Highlighted

Re: Podcasts disappearing from "Your Library" menu

Roadie

Same here. Support suggested me to create a new account and they will transfer all my followers and my library...I thought to be the only one.

Highlighted

Re: Podcasts disappearing from "Your Library" menu

Rock Star 17
Rock Star 17

Hey @Lorenzo_NGG and @dk45-au

 

The right teams are currently working on a fix for this issue.

Keep your eyes on this thread and follow the status update. 🙂

 

Have a nice day!

SebastyRock Star 17
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.
Highlighted

Re: Podcasts disappearing from "Your Library" menu

Newbie

Podcasts has disappeared today on windows desktop app also

Highlighted

Re: Podcasts disappearing from "Your Library" menu

Regular

same here. it's really annoying if we must search our fav podcast.

Highlighted

Re: Podcasts disappearing from "Your Library" menu

Newbie

This is happening to me too. I have to keep uninstalling and reinstalling in order to get it to appear. It seems like the new update is causing it so I guess for now I'll skip updating.

Highlighted

Re: Podcasts disappearing from "Your Library" menu

Casual Listener

This is so frustrating! 50% of what I listen to is podcasts. I recently started using Spotify and have a premium account. I so want to love this service but with little bugs like this and their customer support they're really making it hard.

 

You have a problem? We'll start you a whole new profile and maybe everything will move over. If enough people complain we might have a meeting and possibly decide to fix the problem.

 

Please please please fix this asap! Mine updated this morning without me approving it and now my podcasts are such a pain in the **bleep** to browse to. This seems to be such a huge service and sometimes I feel its going to go fall by the waist side eventually.

Highlighted

Re: Podcasts disappearing from "Your Library" menu

Casual Listener

Still not fixed, just reinstalled Spotify & the Podcast option is still not showing in the Library menu, not good enough that this is taking so long for what should be a simple fix.

Highlighted

Re: Podcasts disappearing from "Your Library" menu

Newbie

SO FRUSTRATING!

any updates on getting this fixed?

 

Highlighted

Re: Podcasts disappearing from "Your Library" menu

Regular

@illorens wrote:

SO FRUSTRATING!

any updates on getting this fixed?

 


not yet

SUGGESTED POSTS