Remove from startup

Solved!
Reply
12 people liked this

Remove from startup

cwolff11
Newbie

Spotify automatically starts up when I turn my computer on. How do I stop that? I am using windows 7 os.

 

 

6 ACCEPTED SOLUTIONS

Accepted Solutions
Solution! 26 people liked this

Fix for Spotify startup

ISanders
Newbie

I had the same issue, spotify prefs, registry keys, msconfig, startup folder, and 3rd party boot utilities (ccleaner, glary utilities) would not work, or was not able locate the Spotify startup files. Here are the steps if all else seems to not work.

 

First open Spotify if it is not already running.

 

(1) Delete the Spotify Icon on your desktop if you currently have one. (Any Spotify shortcuts created before completing these steps will no longer work).

 

(2) Open task manager (ctrl + shift + esc)

 

(3) Switch to Processes tab and Right-Click "Spotify.exe" and select "open file location".

 

(4) In this folder you should see two application files named, "Spotify" and "SpotifyLauncher".

 Right click each file and add a 1 to the end of the file name.

"Spotify1" and "SpotifyLauncher1"

 

(5) Right click Spotify1 and select create shortcut. It should make a shortcut icon which you can drag to your desktop. (This file can be renamed to anything as long as the target is not changed).

 

Once this is complete, it should no longer load on startup. You can now use the created desktop shortcut to open Spotify.
Hope this helps - IS

 

 

Solution! 22 people liked this

Re: Fix for Spotify startup

klutchrider
Newbie
It's under Preferences, click on Advanced Settings. Under (Startup and Windows Behaviour) is the setting that you need. Was annoying me to but found the solution.
Solution! 5 people liked this

Re: Remove from startup

johnleonrd
Newbie

I just installed (06/19/2017) Spotify so should have newest version.

click on down arrow  its to the right of profile button in upper right of page.

click on settings.  Scroll down to end of settings then click on "advanced settings"

Scroll down to "Startup and Window Behaviour"  Subhead says "Open Spotify automatically.

Down arrow gives three choices.  Choose "NO".   Restart..  Spotify  should not start.

And shortcut on desktop put there on installation should now work

Solution! 40 people liked this

Re: Remove from startup

muk0
Newbie

In nowadays, Spotify opens on startup, i disabled this option but it still opens.

I removed from msconfig, but it appeared in msconfig again.

Please fix this

Screenshot_815.png
Screenshot_816.png
Solution! 7 people liked this

Re: Remove from startup

Melainis
Newbie

I had this problem and changing the settings and restarting didn't work. Go to task manager<startup<spotify and select disable then restart. That worked for me.

Solution! 4 people liked this

Re: Remove from startup

spacewarper
Casual Listener

I solved this by disabling Open Spotify after you log into your computer (set to No) AND Allow Spotify to be opened from the web under Preferences... > Advanced Settings.

If you don't disable the second one, the process called SpotifyWebHelper.exe is launched at startup and for some reason it decides it's time to launch Spotify too.

Yes this will prevent you from opening Spotify links (you can still see them in your browser) but I guess this will be sorted out at some point.

168 Replies
24 people liked this

Re: Remove from startup

Community Manager
Community Manager
Hey!

You should be able to do this by popping into 'Preferences' ('Edit' at the top of your Spotify). It should be down the bottom of the page.
-------

Check out how we're doing over @SpotifyStatus

Question answered? Just click 'Accept as solution' to help other users out. Easy.

Who's your Spotify Star?
26 people liked this

Re: Remove from startup

bluefirepatrick
Casual Listener

Except that when you select 'do not open automatically'  it still begins on startup.  I have checked the usual places on Windows for startup items.  THis is annoying- please help.

35 people liked this

Re: Remove from startup

bluefirepatrick
Casual Listener

I have looked into this a bit more.  In the AppData Roaming directory for Spotify there are two files: setting and spotify.args -these both mention autostart even with the option 'off' in the SettingsPanel (as mentioned above).  Please provide values for these files so that it does not autostart.  I am about to uninstall and cancel. Apps should not take the liberty of autostarting.  I love Spotify but want it to run when I choose to run it.  This is a deal breaker.

14 people liked this

Re: Remove from startup

George
Roadie

Have you checked whether Spotify is set to autostart from msconfig?

 

Start >> Run >> msconfig.exe

(or in Windows Vista / 7 without a run command, just type "msconfig.exe" into the search box on the start menu, and hit enter when it finds the executable)

 

Under the start up tab look for an item called spotify, then just untick it. Save those changes and see if that fixes it?

--
First was the record, then the cassette, the CD, then came along Spotify... that really did change everything!
4 people liked this

Re: Remove from startup

bluefirepatrick
Casual Listener

Yes, even with Spotify unchecked in Startup items under msconfig the App still starts automatically after restart.  The Startup Items directory is clear too and the Don't open automatically option is selected in Prefs.  This is on Windows 7 SP 1 with your latest version.  

Re: Remove from startup

George
Roadie

You mentioned the settings file in AppData\Roaming\Spotify...

 

I've just had a look at mine (which was set to not open automatically), and found no parameter that referenced to automatic starting.

 

However, after changing my preferences so that spotify should open, and then exitting Spotify (to prompt it to update the settings file), I've found a parameter called: "autorun_type" has been added.

 

Can you check whether such a parameter exists in your settings file?

--
First was the record, then the cassette, the CD, then came along Spotify... that really did change everything!

Re: Remove from startup

bluefirepatrick
Casual Listener

So with the setting of 'Dont open automatically' it seems to remove that param.  When I set it to 'Open automatically' in the App it sets that param with a value of 1.  'Open auto but minimized' sets it to 2. 'Dont open' then removes the param again.  I tried setting it to 3 by hand and restarting but it still autostarted and the preference was set to' Open auto but minimized' in the prefs. 

Re: Remove from startup

adfsk12
Casual Listener

Has anyone found the solution to this? Spotify comes up every time I start up, but even though I've checked the button in preferences that says for it not to.

14 people liked this

Re: Remove from startup

etsybay
Newbie

:manmad: uninstalling!

 

This is too frustrating

SUGGESTED POSTS