Announcements

Help Wizard

Step 1

NEXT STEP

Songs won't play, and now are not appearing

Solved!

Songs won't play, and now are not appearing

Plan

Premium

Country

US

Device

PC

Operating System

Windows 10

 

My Question or Issue

Hi, so I've been looking at many solutions and answer regarding my issue.. None have worked. So for awhile, my songs on spotify (Only on PC) would play, then after 4 seconds just stop and Spotify would tell me "Can't play current song" so after doing a few clean re-installs, and deleting caches and such, now, none of my music is there. When I click on my main list (Which is supposed to have over 500+ songs) it now only has 100 of my local file songs I previously added which are now of course greyed out. Before I lost all my songs, the only thing that got them to play for those few seconds was switching my quality to normal, but I have Premium. So I shouldn't have to do this. My songs are still on my phone and my girlfriends phone. But I would like to be able to have my local files back on my phone and to listen to Spotify on the PC.  If there are any other solutions besides just re-installing Spotify, this would be appreciated, as I see that answer come up a lot. But after 4 times, it has not worked. 

 

Thanks!

Reply

Accepted Solutions
Marked as solution

Hey @user-removed 

 

I'd suggest checking out your hosts file. I've seen other users having issues similar to yours and that was the culprit. 

 

Check out this Answer article on how to get behind this. 🙂

 

Let me know how you get on!

View solution in original post

3 Replies
Marked as solution

Hey @user-removed 

 

I'd suggest checking out your hosts file. I've seen other users having issues similar to yours and that was the culprit. 

 

Check out this Answer article on how to get behind this. 🙂

 

Let me know how you get on!

Wow, that actually worked beautifully. There was one line pertaining to Spotify, I deleted it. All songs work, they're downloading, and now I'm gonna add the local files back on my phone!

 

Thanks!! 🙂

Yes!  Some overly agressive antiblock or anti-malware software added a spotify row to my hosts file that was preventing Spotify from connecting back to the mothership. 

 

Songs just wouldn't play.

 

I deleted the row from the hosts file, and all is fixed.

 

Great!

 

Suggested posts