Announcements
We’re aware of some issues right now affecting our service and are checking them out! We'll keep you posted here.

Help Wizard

Step 1

NEXT STEP

FAQs

Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...

VIEW ALL

Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...

VIEW ALL

Speaker only playing left channel

Solved!

Speaker only playing left channel

Plan

Free

Country

UK

Device

PC 

Operating System

Windows 10

 

My Question or Issue

I just plugged in my UMC404HD audio interface to my speakers (BEHRINGER MS40s) - this is all connected via USB to my PC. Every other programme/website outputs stereo, except for Spotify. It even gave me an error at some stage "Spotify can't play this right now. If you have the file on your computer you can import it." I disabled 'Enable hardware acceleration' under Compatibility in advanced settings but still problems persist - either error described above or only left speaker output. Not a cable issue, tested everything.

Reply

Accepted Solutions
Marked as solution

Try downloading the drivers for the interface again, it worked for me when I did it and spotify works fine now. After downloading the drivers correctly, in windows the device should show OUT 1-2 (BEHRINGER UMC 404HD 192k). Before it only said UMC404HD 192k and only played out of the left speaker. You should also have the UMC control panel on your computer once you install the correct drivers.

View solution in original post

23 Replies

Hey @jonas404 

 

I'd suggest two things:

1. ensure the audio device is set as default audio output in the Windows' sound settings.

2. reinstall Spotify to clear out any potential file issues.

 

You may also try disabling the onboard audio (Realtek or whatever it might be) in Device Manager, so the Behringer device is the only (and always default) audio device.

 

Let me know how you get on 🙂

SebastySpotify Star
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

Hi Sebasty

 

Reinstalled Spotify and UMC404 is now defaulted. The play button doesn't work.

 

When I press it I can visually see a small glitch and then nothing happens (no error popup displayed either).

 

Again, all other software is working as well as online browsers. I tried Spotify web player and it works fine.

@jonas404 

 

Apologies for slight delay.

If you use other audio (onboard audio for example), then Spotify works?

 

Ensure all Windows updates are installed (anything driver-related especially).

Reinstalling the audio device's drivers could help too.

 

I checked your audio interface's specs, it seems that 192kHz is highest sample rate it uses. In case it's even higher, I highly recommend choosing a lower setting because Spotify is known to not work at sample rates above 192kHz.

 

Let me know how it goes! 🙂

SebastySpotify Star
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

I actually tried to install spotify, it works all the time for me, it has really unbearable bugs nowadays, just imagine my face full of surprise and unexpectedness when I decided to finally order center channel speaker and listen to all films and dialogues, tv shows, music and everything with pure sound. Boom and spotify has bugs which are still not revised and corrected. Music still remains a big problem because of spotify, meanwhile all other films, tv shows are my favorite ones now because of this best quality sound. I've ordered Polk Audio T30 owing to https://www.palmgear.com/best-center-channel-speaker-for-dialogue/and I'm really satisfied with the quality!

I am having this same exact issue with my UMC404HD interface, Spotify works fine playing stereo with the web player, but not the desktop app. When using the desktop app I will either have only my left speaker work, or "Spotify can't play this right now. If you have the file on your computer you can import it." Has anybody found a fix?

Hi @imHarrison

 

Thanks for reaching out about this in the Community. 

 

Would you mind letting us know if you've already performed a clean reinstall of the app? This could be helpful for clearing any cache that might be causing issues. It will also get you the latest app version. 

 

If this doesn't do the trick, could you send over your device's make, model, OS version and Spotify version so we can take a better look? 

 

Keep us posted. We'll be on the lookout for your reply.

NovyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

I did a full reinstall of the app and the issue still persists. I'm on a PC on the latest version of windows 10, and this only happens on the desktop app, not the web player. At first it skips every song and then gets stuck not being able to play anything, and says "Spotify can't play this right now. If you have the file on your computer you can import it." until I switch the audio to my headphones (which will work fine). When I switch from my headphones back to my speakers, it only plays the left channel.

Hey @imHarrison,

 

Thanks for getting back in touch and for that info.

 

We recommend checking your PC's sound settings and make sure that Spotify is enabled to be played on stereo on your sound system. 

 

Also, make sure that the firmware/drivers of your audio interface are up to do date. It's also worth reinstalling the drivers to make sure everything is up to speed and there aren't any corrupted files causing trouble.

 

Keep us posted on how it plays out.

CarlosEModerator
 
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 

Hey I wanted to add to the conversation, I think you are heading in the wrong direction with the troubleshooting. I'm also using a Behringer UMC204HD on a fresh install of Windows 10, fresh install of Spotify, and I'm having the exact same problem. Spotify will either not play at all with the error "spotify can't play this right now" or it will play but only through the left channel. I believe this is a bug with the Spotify desktop app itself and how it is interacting with the Behringer UMC204HD.

Hey there @SwitchK,

 

Thank you for your reply and feedback.

 

Just to confirm, have you tried the troubleshooting steps that's been provided in the thread?

 

We'll keep an eye out for your reply.

 

Cheers!

JeremyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Live, love, laugh and listen to music 🙂

Yes. Clean install of Windows, clean install of the UMC204HD drivers, clean install of Spotify, UMC204HD set to default playback device. All other applications, including Spotify web player, all play in stereo from the UMC204HD. The only application that will not play in stereo over the UMC204HD is Spotify desktop or doesn't play at all with the error "spotify can't play this right now". When I get the "spotify can't play this right now" error it can be circumvented by changing the default playback device to another output, start playing music in Spotify desktop, then changing the default playback device to the UMC204HD. This does not resolve the single channel audio issue. 

Hi again @SwitchK

 

Thanks for getting back to us. 

 

Would you mind letting us know if Spotify works fine on your desktop when you're not using the UMC204HD?

 

You can also try disabling hardware acceleration by clicking the three-dot menu on the top left of the app > select View > uncheck Hardware Acceleration > Restart Spotify.

 

Let us know if you notice anything new.

NovyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Spotify desktop works fine with all other devices; for example my Bluetooth headphones and my motherboard's onboard sound card both work fine. Turning off hardware acceleration didn't improve things, it just added a bunch of visual glitches.

Hey @SwitchK

 

Thanks for your reply.

 

Could you try disabling and re-enabling all audio devices through Windows to see if that makes any difference?

 

We'll keep an eye out for your reply.

NovyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!
Marked as solution

Try downloading the drivers for the interface again, it worked for me when I did it and spotify works fine now. After downloading the drivers correctly, in windows the device should show OUT 1-2 (BEHRINGER UMC 404HD 192k). Before it only said UMC404HD 192k and only played out of the left speaker. You should also have the UMC control panel on your computer once you install the correct drivers.

@novy No. That made no difference.

@imHarrison I'll give that a try.

Do you at least have the UMC control panel on your computer? I actually had to find the drivers from another site that wasnt the behringer website for it to work

Hey folks, 

 

Thanks for your messages. 

 

@SwitchK, could you let us know if @imHarrison's suggestion worked for you?

 

Keep us posted.

NovyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

I do not have the UMC control panel. I didn't even know it was a thing. I was about to download the drivers from Behringer's website but now I will hold off. Where did you find the drivers that contain the UMC control panel?

 

Right now I'm using the drivers provided through Windows Update.

Suggested posts