Spotify: A firewall may be blocking spotify. Please update your firewall to allow spotify.

Solved!
Reply
Highlighted

Spotify: A firewall may be blocking spotify. Please update your firewall to allow spotify.

polariq
Visitor

Plan

Free

Country Canada

 

Device

Windows 10

 

My Question or Issue

Everytime i try to login my spotify account, the firewall issue keeps on coming up. Ive tried to delete it, check if my country is still the same, tried a different account, tried a vpn, everything.

spotify glitch.png
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Solution!

Re: Spotify: A firewall may be blocking spotify. Please update your firewall to allow spotify.

mrfirespark
Regular

Hey!

 

I had this same issue when I first joined Spotify.

 

There are a few ways to fix it. Mine was a little more complicated than some other ways. Heres how I fixed mine.

1) In the windows search bar type in Windows Defender Firewall

2) Once you click the first box it should bring you to a control panel page. On that page in the top left corner, click "Allow an App or Feature".

3) Make sure to click the "Change Settings" button at the top.

4) Scroll down to any and all items labeled Spotify and allow them both publicly and privately.

5) Restart your computer after saving the settings.

 

If that doesn't work, make sure you're on the latest version of Spotify and ALSO make sure your internet connection isn't blocking it if your home/school network has protections installed.

 

I hope I was of help.

 

-Colin

 

View solution in original post

2 Replies
Highlighted
Solution!

Re: Spotify: A firewall may be blocking spotify. Please update your firewall to allow spotify.

mrfirespark
Regular

Hey!

 

I had this same issue when I first joined Spotify.

 

There are a few ways to fix it. Mine was a little more complicated than some other ways. Heres how I fixed mine.

1) In the windows search bar type in Windows Defender Firewall

2) Once you click the first box it should bring you to a control panel page. On that page in the top left corner, click "Allow an App or Feature".

3) Make sure to click the "Change Settings" button at the top.

4) Scroll down to any and all items labeled Spotify and allow them both publicly and privately.

5) Restart your computer after saving the settings.

 

If that doesn't work, make sure you're on the latest version of Spotify and ALSO make sure your internet connection isn't blocking it if your home/school network has protections installed.

 

I hope I was of help.

 

-Colin

 

View solution in original post

Highlighted

Re: Spotify: A firewall may be blocking spotify. Please update your firewall to allow spotify.

mrfirespark
Regular
(or try turning off your firewall completely. It's enabled by default) 😄
SUGGESTED POSTS