Announcements

Spotify does not play with external speakers (desktop)

Reply
Highlighted

Spotify does not play with external speakers (desktop)

Visitor

 

Plan

Free

Country

Belgium

Device

Asus Rog Strix G

Operating System

Windows 10

 

My Question or Issue

Hi,

my spotify starts skipping every song when i have my desktop connected to an external speaker system, when i play it with the built in speaker prom my asus it has no problem yet the music quality sucks compared to the external speakers.

 

My extrenal music speakers have no problem playing from any other music source (youtube, stored music, mixing program), so i do not think it will be a conenction problem.

 

Im using 2 krk studiomonitors connected to my pioneer mixing pannel wich in turn is connected to my asus via usb.

 

 

3 Replies
Highlighted

Re: Spotify does not play with external speakers (desktop)

Rock Star 17
Rock Star 17

Hey @kenzo1612 

 

This is most likely caused by Spotify stuck to using the internal soundcard instead of your Pioneer. Windows 10 allows users to choose what applications use which audio outputs and that's where I recommend to take a look. Check out this HowToGeek article for more information on that. 🙂

Let me know how you get on!

SebastyRock Star 17
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.
Highlighted

Re: Spotify does not play with external speakers (desktop)

Newbie

Not working. Webplayer is playing Spotify without problems. App is saying that we are playing through webplayer so I can control on other devices but it's ridiculous that this is not working anymore. 

Highlighted

Re: Spotify does not play with external speakers (desktop)

Moderator
Moderator

Hi there @One23,


Thanks for the reply.

 

Have you tried changing the default playback device on your windows system. You can do this by going into Windows Settings > Sound > Output

 

You can also try selecting a specific output device for Spotify from the same Settings panel, scroll further down and you should see Advanced Sound Options > App volume and device preferences. From there you can choose your preferred audio output.

 

Let us know if that makes any difference.

AlexModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“With freedom, flowers, books, and the moon, who could not be perfectly happy?” ― Oscar Wilde
SUGGESTED POSTS