Announcements

Help Wizard

Step 1

NEXT STEP

FAQs

Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...

VIEW ALL

Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...

VIEW ALL

Spotify insists on being offline, despite PC having internet access

Solved!

Spotify insists on being offline, despite PC having internet access

Plan

Premium

Country

Mexico

Device

Desktop PC

Operating System

Windows 10

App version

1.1.40.508.gd5bc2931

 

My Question or Issue

I've had this issue for months. MONTHS. I've only been able to listen to Spotify through my phone, since the windows app has just refused to work. No matter what I do, it insists it's offline even though it's plugged to the internet via ethernet. I've reinstalled it time after time, read through dozens of solutions, and nothing's worked. 

 

What I've tried:

-Clean reinstall

-Adding firewall exceptions

-Adding antivirus exceptions

-Looked for conflicting drivers

-Checked the proxy settings in the app, tried switching back and forth from "Auto Detect" to "No Proxy"

-Logged out, logged in, constantly

-Rebooting my pc to **bleep**

 

It's really frustrating. This isn't a new issue. Please advice.

Reply

Accepted Solutions
Marked as solution

As a Hail Mary attempt, I tried this which actually worked:

1. With Spotify closed, go to Windows' Device Manager
2. Check Network Adapters
3. Double click the currently used network adapter
4. Go to the 'Advanced' tab
5. In the properties list, look for 'IPv4 Checksum Offload', click on it
6. If it's set to 'Rx & Tx Enabled', change it to 'disabled', apply changes
7. Wait about 30 seconds for changes to take effect and then open Spotify
8. Profit

Note: my in-app proxy preferences were set to "Auto Detect".

By the way, this is a solution not provided by the Spotify team, and I translated it from spanish. I'm not even sure what it does, but in case anyone's having this same issue, hopefully it will solve it for you as it did for me.

View solution in original post

1 Reply
Marked as solution

As a Hail Mary attempt, I tried this which actually worked:

1. With Spotify closed, go to Windows' Device Manager
2. Check Network Adapters
3. Double click the currently used network adapter
4. Go to the 'Advanced' tab
5. In the properties list, look for 'IPv4 Checksum Offload', click on it
6. If it's set to 'Rx & Tx Enabled', change it to 'disabled', apply changes
7. Wait about 30 seconds for changes to take effect and then open Spotify
8. Profit

Note: my in-app proxy preferences were set to "Auto Detect".

By the way, this is a solution not provided by the Spotify team, and I translated it from spanish. I'm not even sure what it does, but in case anyone's having this same issue, hopefully it will solve it for you as it did for me.

Suggested posts