Announcements

Spotify not showing all songs from iTunes or Local Files

Solved!

Spotify not showing all songs from iTunes or Local Files

JustJacalyn

I love the fact that I can use spotify to listen to my songs on my desktop, laptop and iPhone and it's allowed me to be introduced to artists i'd never heard of until now! But I'm having an issue that's driving me to my witt's end!

 

I'm desperate to get a song on my spotify playlist that i have in iTunes but it won't even show up in Spotify. Only abou 1/5 of my music shows up in spotify, and this song is one of the one's that doesn't. 

 

I read a whole load of threads and saw it mentioned iTunes like's mp4, and Spotify likes m4a - so I changed the format but no luck. I also saw mentioned about downloading Quicktime - still no luck. Any help would be greatly appreciated as this particular song isn't on spotify (the non live version is but lets face it sometimes the live version is better!)

 

 

Many thanks in advance - a spotify fan and converter of many.

Reply

Accepted Solutions
Marked as solution

Taylor

Hi,

 

Have you tried creating a folder and putting all your song files in it; then going to Edit>Preferences and find the local files section , then press 'Add source' and select the folder?

 

If it doesn't work, might be worth trying a clean reinstallation of Spotify.

 

Anthony 🙂

This post was by Taylor - I do not work for Spotify!
If this solved your issue - Mark it as a solution! If you like my post - Please add Kudos!
||  Spotify Profile - Taylor   |  Feel free to PM me - Here  ||

View solution in original post

13 Replies

Joe

What happens it you drag the track from itunes into the desktop client - any error messages?

JustJacalyn

Nope, does nothing at all. I tried dropping and dragging from itunes and where the song is directly on my computer as well, and it just showed it being dragged but when i dropped it nothing happened.

Marked as solution

Taylor

Hi,

 

Have you tried creating a folder and putting all your song files in it; then going to Edit>Preferences and find the local files section , then press 'Add source' and select the folder?

 

If it doesn't work, might be worth trying a clean reinstallation of Spotify.

 

Anthony 🙂

This post was by Taylor - I do not work for Spotify!
If this solved your issue - Mark it as a solution! If you like my post - Please add Kudos!
||  Spotify Profile - Taylor   |  Feel free to PM me - Here  ||

JustJacalyn

IT WORKED! LIFE SAVER!

Songs will be sung in your name by future generations. You will become a man of myth and legend but only I will know the truth and that my rescuer was called Anthony.

 

Yep.... That Happy.

ParticleMan

Came across this thread - found another possible solution incase anyone else is looking. It turns out you can't specify "iTunes" as the root folder. Sportify will not recognize any music in that folder.

 

Instead choose /iTunes/iTunes Music/

 

Which worked perfectly and will index all of your locally installed music.

 

Cheers

Steve

hangdang

I know this thread is crazy old, but it's the first one I saw on Google.  I have Spotify set to take my music from a file path that looks like this:

D:/Music

 

It seems to be okay, but stopped loading any artists past the letter J.  Have tried a clean install and no luck so far.

berrypippin
How can I do this on my iPhone? I recently downloaded some songs from iTunes, but how do I get them to show up on Spotify?

mariah-075

Thanks for the speedy reply, i will try that.  I tried downloading itunes and quicktime and spotify isnt even recognizing i tunes so a reinstall is probably a good place to start.

 

Thanks!

m_kelly

I'm having the same issue but I made it to "P"

 

Any luck sorting this one out?

xn00b514y3rx

I tried that and it did not work. It still doesn't play the song I wanted to. Does it have anything to do with the file type? because mine is a .wav which is wave sound.

Ctrlindel

If anyone still has this problem, changing the name of the folder were the songs are in helped me 🙂

ThatPieGuy

This worked for me as well. Not sure if it will have the same problem again in the future but at least it's an easy (maybe temporary) fix.

ToStaSa

When I press 'edit' from the bar above (I'm on an old osx mac) there is no "preferences".

Suggested posts

Env: prod