Spotify now skips all tracks unless started with "Run as Administrator"


Spotify now skips all tracks unless started with "Run as Administrator"







Windows 10

Operating System

Windows 10


My Question or Issue

Not sure this started with recent windows updates I did yesterday but now spotify will only play anything if I started with "Run as Administrator", I've tried all the following things:

Complete uninstall (and check no folders left over)

Reinstall from app store

Changed the directory to somewhere else

Enabled/Disabled hardware acceleration

Uninstalled my sound drive and reinstalled


Basically when started and I click Play it literally just goes through each song but not playing them.


Driving me mad.


2 Replies

Casual Listener

Same here.

I have recently changed sound card.

Spotify Legend

Hey @tonyrogerson and @BadWeasel,


Thanks posting here in the Community! We'll gladly help you out.


Just to make sure that we're on the same page - did you perform a clean reinstall using the steps here? They are more thorough and should do the trick with such playback issues. If that doesn't fix things, it's also a good idea to check your hosts file for Spotify entries. This page explains how to do this. Make sure to also restart your device, this is a simple, but often overlooked step.


@BadWeasel did you also disable the hardware acceleration in the advanced settings menu? It may be the case that your recent change in hardware is conflicting with this option. Are you experiencing any other sound issues since the swap?


If the issue persists could you let us know you Spotify version, as well as the make, model and OS version of your device? It'd be great if you could also attach a video of what you're seeing. Just make sure to hide any private/sensitive info.


Keep us posted how you get on.

Mihail Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!