Spotify on Raspberry Pi with Moode Audio

Spotify on Raspberry Pi with Moode Audio







Operating System

 Android 12, Windows 11


My Question or Issue

I play Spotify on my Raspberry Pi 4 using Moode Audio. I have Spotify Connect integrated in Moode Audio, so I can click "Play on other device" on the bottom of the page of Spotify and select "Play on Moode Spotify". 


It used to work fine with Windows 10 and an earlier version of Android, but now I use Windows 11 and the last version of Android and it stopped working. I can still select Moode Spotify in the list of other devices, but when I do I hear no sound. 

 I updated both the Spotify app in Windows and Android, I have the last version of Moode Audio and the connection between my computer and Moode is fine (I can also listen to radiostations on Moode and there is sound. I have full control over my Moode Audio).


Does anybody have any suggestions on how to get my music playing...?



23 Replies

Hey @Peterman45,


Thanks for posting on the Community and welcome 🙂

We'd like to gather more info about this. If you log in with another account, do you experience the same? It'd be awesome if you could check. You can create a free test account to check if the inconvenience persists there.

On another note, do you notice any difference if you switch the internet connection you're using? You can create a hotspot with your phone. Give it a try and let us know how it goes.

We'll be on the lookout for your reply.



Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.

Hello Alejar,


I can confirm Peterman45's problem. I am experiencing the same issue with both Moode Audio 8.1.2 and 8.0.2.

Something changed in either the Spotify Connect protocol or in the librespot library (less likely since two releases are affected).  I can use it for all other devices I own (native apps on macos , ios/ipados, linux  and windows).






Hello AlejaR,


Thank you for your response.

Unfortunately Moode only functions with a Spotify Premium account, so a free test account is not an option. 

I have two different wifi internet connections, one that works on 2,4 Ghz and one on 5 Ghz. Neither network gives me sound from Spotify. I have to make clear that the Moode Audio on my RP 4 has a ethernet connection (cable).

Even when I use my phone to play Spotify on a 5G internet connection, it doesn't give me any sound, although Spotify tells me it is playing on Moode. Which was possible before. 

So to me it doesn't look like a problem with my network. 





P.s. I asume that you are totally familiar with the Raspberry Pi 4, Moode Audio and how it works... 


Hi Peter! @Peterman45


I've heard of the Raspberry Pi, but I can't say I'm familiar with it, however, other users who were experiencing issues with Spotify Connect reported that changing the DNS seems to have done the trick, so it's worth trying if you haven't already. Try the following ones to see if it would solve the issue:

  •, suggested by a user here.

Let us know how it goes. Cheers!

Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Hello Yordan,


thank you for your answer.

Sadly it is not a DNS problem. I have google dns ( and in all my devices including Rpi4

with Moode Audio and the problem is still present. I also changed them with no results.  BTW i tested ping towards

spotify endpoints and they works like a charm.

I suspects it is a protocol/library issue.








Hello Yordan, everybody,


Well, I have tried your suggestion but unfortunately it didn't make any difference. The Raspberry Pi is a Linux based mini computer, with just a motherboard, a soundcard, a network connection and connectors for my speakers. It (Moode Audio) is visible in my wifi network, so I asume it isn't a issue with DNS or IP.

But I have also searched for a solution in the community of MoOde, and after all the problem seems to be with MoOde... More people are complaining about losing the sound, not just they who use the Spotify plugin. There seems to be a bug in the software which shuts off all the audio signals coming from external sources like Spotify, other than Moode itself.

There is a solution, but because I don't know anything about Linux and I am not able to dive into the program, I decided to switch (back) to Volumio. For those who want to make the same switch: use Volumio 2, not the latest Volumio 3, that one hasn't the Spotify plugin yet. 

I installed the program and within 5 minutes I was enjoying my music from Spotify Connect again!


I want to thank AlejaR, Yordan and the other people working on the background for working with me and for your effort in finding a solution! Thanks for the energy you put in.


Cheers and have a great weekend!


Hello everyone,


The strange thing is that I am using Moode Audio with all other internal and external channels (Airplay, DNLA, Radio, etc.) and all works like a charm. I even tested a Tidal account of a friend via UPNP and works.

The only channel that is not working is Spotify... 

For me switching to volumio is not an option, I have all my setup centered on Moode Audio.

I would like to understand if the issue is on Spotify Connect side or on Moode Audio (i.e., librespot).

The strange thing is that it stopped working suddenly and I had automatic updates disabled. This hints me that something

in Spotify Connect , used by librespot, has been changed. Is there someone in the Spotify support helping understand what's happening?





I was wondering the same thing; I haven't updated or made any changes to the Moode software (was using it for 6 months without any issues), it worked fine and from one day to the other it stopped playing sound. What has changed? My version of Windows on my laptop and the version of Android on my phone. But even after those changes Moode has worked fine for a while. The only change could be with Spotify Connect, that was the reason I started this thread.


I have searched a lot on the internet on problems with Spotify Connect, Moode, RPi4, etc., and I can't recollect in which forum or community I read about other people having the same problem. I wrote it was on the Moode Community, but now I am not sure anymore.

You mentioned Librespot, and that is something I saw coming by in more posts. I am not that familiar with those things, so reprogramming an operating system is not something I would do, not even Linux. For that reason I went back to a working program like Volumio and just enjoy my music.

If I retrace my tracks you might find something about it here:


I hope you will find a solution. Good luck!

Hi, same Problem here, no solution found yet.

Using HifiBerry DAC+ Pro.

Spotify starts playing (not audible), then skips to next track and so on or pauses the track. no error messages or anything.


Yep, that's also a thing. Just starting the first 2-3 seconds of a song and then skip to the next. 


@the people from Spotify; it's awfully quiet now... The fact that I decided to make it easy on myself by switching to Volumio doesn't mean the problem is solved... I have read, and suggested that one cause of the problem lies with Moode, but I hope that Spotify is also still looking into their software to understand why Spotify used combination with Moode is having problems.


Like I and other people mentioned, the software installed on my Rpi4 (Moode) hasn't changed from the beginning. I installed the program a long time ago and it wasn't updated or there weren't made any changes at all... Still from one day to the other..... Well, you know. So it's hard to believe that the software of Spotify has no part in creating the problem. 


There has got to be more to say than 'look into your own network' . I suggest they have a better look at Spotify Connect and especially to what happens when it is used on a RPi or a simmular system. 


So I hope AlejaR, Yordan and the others are still reading this thread and are still working on a real solution!






I can also confirm that there is an issue. I didn't change anything on my side (e.g. R Pi 4 & moOde) and it stopped working a couple of weeks ago, so I also assume that there must have been changes on the Spotify side. I tried updating my "old" moOde 7.x to the current 8.1 but still same issue.


Will also give Volumio a try now 😞

In case someone else wants to try: The current Spotify Plugin seems to work with Volumio 3 quite fine

Hello all;

I had the same issue last week with Moode on R Pi using Spotify. Everything else ws working fine, except spotify. But after clearing the "Credetial Cache" (Settings -> Audio -> Spotify Renderer) it's working again. Maybe this does the trick for you as well.

We experienced a problem with Volumio that after each song the volume gets set to 100% again - which is quite noisy ...


So I switched back to moOde: I logged in via ssh and did

sudo apt update
sudo apt upgrade

This installed a newer version of librespot and some other updates, and now it's working for me as before, I'm so happy!! 😁

I had this issue with no sound. Default audio level is 0 on Moode for Spotify. So, in Moode, I went to Configure-Audio-EditSpotifyconfig-InitialVolume% changed it 100 or whatever. I don't adjust volume on spotify client. It acts wierd with Moode. So I needed this set.

Same issue. Moode 8.2 on a RP4 will not run Spotify. It will connect, but as soon as I hit play in Spotify it will switch back to the local device audio output (MacBook Pro M1, iPad Pro, iPhone 13). In the browser it will say "Spotify Active" but is not. Tried all the above suggestions (and more), but to no avail.

Of course. Have a look at this thread. It is a Spotify Connect issue. A future Librespot 0.5.0 version should fix this.

One thing I've found when Spotify connects to moode and says it's playing but there's no sound is to change the audio - ALSA -output mode to 'default (plughw)'. I normally run moode in 'direct (hw)' mode but I get no sound from spotify if I use direct (hw).

Suggested posts