Help Wizard

Step 1


Spotify won't play some podcasts

Spotify won't play some podcasts

Some of the podcasts can play, but others just won't start. I tried them on my phone and they work just fine, but when I switch to my computer they never start.

I'm from Argentina and I have Spotify Premium, I'm using a desktop computer with Win 7



6 Replies

Try that:

Open your notepad as administrator, then open the "hosts" file in:


You should see a lot of # and

Delete all the lines with "spotify" or "fastly" in it, then save, close your notepad.

Now close and re-open Spotify

There are no lines that say either of those

Then i don't know sorry

I'm having the same issue.  Specifically F1: Beyond The Grid won't play on my desktop.

I have the same problem. My Android devices play all the podcasts just fine but the desktop app has issues. Actually for me it works so that whenever I click the play button for some podcast episode, nothing happens. But if I just leave the playback running, after maybe 10 minutes the app suddenly starts playing the episode normally.


I can live with that if I have to, but it's really annoying to wait for >10 minutes every time I want to listen to some episode in the desktop app. My network connection is fast, so that can't be the issue. The problem is limited to some podcasts only, some start playing normally right away. 

I'd like to know what is the root cause and is there any solution available / fix being planned? Seems that this issue has been there for quite a long time as I found several old closed threads in this forum about the same topic. 

EDIT: This may be Windows 7 issue only, as I haven't noticed this when using my other PC running Windows 10. My Win7 Spotify version is

Same here re the F1 Beyond The Grid podcast (as well as several other podcasts). Some work fine.

Some no response at all - except the play button is replaced by the pause button (so it appears it's playing, but there's no sound and no movement on the timeline).

They play fine on my Android device though.

Using Windows 7 Home Premium.
Located in Australia.

Spotify version

Have tried rebooting the PC as well as reinstalling Spotify

Suggested posts