Help Wizard

Step 1



Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...


Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...


Tracks supposedly running, but no sound


Tracks supposedly running, but no sound

Hi all,

  I've got Spotify up and running, with no error messages.  However, when I press play, no sound comes out  The countdown/timer thing on the bottom is working fine, but I don't hear a thing.


I'm thinking that re-installing it might solve the problem, but will I lose my starred list/playlist if I do that?  


I have Spotify Free at this moment.

40 Replies

@Mancalled Could you check the basic FAQ on this and, if that doesn't work, follow the steps in this post. Please let me know the outcome, thanks.

..I've had the same problem with no sound. I've uninstalled mulitple times, and deleted the cache.



Hey! So I just had this issue and read hundreds of things to do- nothing worked. So i just restatrted my computer and it worked!!

THAT WORKED! oh my gosh thank you so much.

Me too! I have been having this problem for months. Almost everytime I use spotify I have to restart it and try again. Sometimes that works and sometime it doesn't. 

I also have the same problem. Although this started with playing 6 songs in a row then no sound. After last update now only 2 songs and no sound. I dont have premium; is this the real problem?

I have premium and have the problem all the time.

I restart all the time and that doesn't work. There has to be some kind of solution. Aggrevating!

Thanks! The first one solved it 🙂 House party saved

I feel like an idiot. That was it!! Thanks! 

So, I have windows 10. Trying to run spotify, but I can't get sound (ticker still moves like a song is playing) and I can't pause, skip, nothing. I've tried literally every suggestion on this 3 page thread with no luck... What the heck is going on with spotify? This is getting really frustrating.

Been having this same problem for about a week now on my chromebook, works fine on my phone and sound works on my laptop for other websites. >:|

I am experiencing the same issue on my pc.  Yes, the time ticker is moving, all of my sound levels are up, nothing is on mute.

This might not be anyone elses problem but in my case I just had ti playing in a diferent device.

By clicking the middle icon in the attached image I could swap to the device I was on and everything started working just fine.

It is always a user error xD

Screen Shot 2018-02-08 at 16.49.47.png

I had the same thing. I'm using a macbook pro 13" 2012 Yousemite. I'm using spotify web player, which I downloaded and which worked fine prior. The volume toggle on my keyboard is on max and works on youtube. The volume toggle at bottom right on spotify player is on full. I have clicked on multiple tracks and places in the tracks. Then I noticed a little devices available icon (hover to see the name) to the left of the volume toggle on the spotify player at the bottom of the screen. It was set to a different family member's computer (I have spotify family plan). I toggled to my computer. Problem solved. 

Having this issue (tracks supposedly running, but no sound) - I've checked the sound in the task bar at the bottom of the screen and the time bar moves as if the song is playing but there still isn't sound. This started happening out of nowhere and I can't listen to spotify on my laptop anymore which is a major inconvenience. Please help!


I do not have any other devices connected - if I toggle to the devices button, I get a "learn more" pop up. So this is not my issue!

I do not have any other devices connected - if I toggle to the devices button, I get a "learn more" pop up. So this is not my issue!

Sometimes I find exiting the Spotify application then reopening helps.

Im facing that issue since yesterday would spotify has a bug? its annoying as the song does not play or to be more precise there is  no sound until i have to hit play

please fix it?

I'm having the same issue but with my car. It shows that it's playing but there's no sound. I'm using Android Auto or just a usb cable if AA is not working. 

Suggested posts