Help Wizard

Step 1



Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...


Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...


[All Platforms][Playlists] Switch on/off crossfade in certain playlists

Hello Community!


In Spotify there are some playlists with automatic crossfade. That means there's a smooth transition between songs. However, not everyone likes that, since the next song starts later (from minute 0:45, 0:26, 1:02...). That's why I thought it would be a good idea a to have the ability to switch it on and off depending on what the user prefers.

That way, there wouldn't be any problems with that.


This is an example of one of the playlists:


In my opinion, it would be a good idea. If you agree, make sure to leave your vote/comment and hopefully they'll consider this idea.

Updated on 2020-01-15

Hey folks,


Thanks for coming to the Community.

As mentioned in many of the recent comments here, you can now head to Settings and turn off 'Automix'.
Hopefully this helps!


I thought this was a bug!

I would definitly prefer to have the option, or even better being able to do the same for personal Playlists.


WOW I thought my client was broken. Is it some sort of AI that automatically does this? I refuse to believe anyone that took the time to put together a playlist went through cropping the ends off. It seems that it only happens on some clients and not others, which I think is the only reason this post hasn't seen the traction it needs for something to get fixed. This should at least honor the option in the spotify account that says not to cross fade, like sure some people might like that but as a musician it drives me up a wall if the fade isn't d@mn near perfect. Maybe the curated playlists should have custom fade settings by the curator (if they know what they're doing) but this ruins most of the playlists I listen to!

never noticed this until using spotify on desktop for windows, my android phone doesn't seem to be plagued by this garbage.


Confused why this needs to be an 'idea'. Given the fact that you have an option to disable/enable crossfade you know that there are people who like it one way or another, why was this ever hardcoded in? What sort of monster likes a 20second crossfade anyway? There's a lot here that I don't understand.


For what it's worth 90% of the value I get out of spotify is using playlists like these, so this is annoying 90% of the time.


This is probably one of the worst features I've ever experienced. It's hard to believe that Spotify would push this out without any options to turn it off. Have they even done extensive testing? Why would someone who enjoys listening to music want to miss part of the next songs? It makes no sense to me. 


Hi everyone- Spotify listened and added an option to turn this off!! Go to settings, playback and turn off AutoMix! So so happy to have playlists back without that awful ‘mixing’. 


@jeff_beck on what platform? I can't see this option on Desktop macOS or on iOS.

iOS. It came in an update 3 days ago. 




I see it now, I had to restart the app for some reason. But this still doesn't completely solve the issue since the desktop app still doesn't have this. Let's see if it comes with the next desktop update. I wonder why they didn't advertise this feature in the app update changelog.


@douira I have it on the desktop version! (I'm running it on PC however) Try restarting Spotify on the desktop too. If you still don't have the option after that, you could check if you can download the update manually.  To do this, do the follwoing:

1. Press the 3 dots in the top left corner.

2. Go to Help > About Spotify

3. If you have an older version of spotify installed, you will have the option to donwload/restart the client to install it. Otherwise you will just see the version of spotify currently beeing installed. (Right under the spotify logo in the window that comes up)

I'm currently runnin version