Announcements

Having trouble seeing your Wrapped stories? To fix this, update the Spotify app to the latest version.

Find more info on our community FAQ.

[AutoPlay] Option to toggle Autoplay on/off across all devices/platforms

Status: Implemented

The Autoplay setting isn't working for connected devices and the web player. We need the Autoplay setting to work the same as it does on desktop and when playing on the phone.

Updated on 2022-02-04

Hey folks,

 

Thanks for coming to the Spotify Idea Exchange and voting to make this happen.

 

We're happy to announce that the option to manage Autoplay has been released for the desktop and now for the mobile app too.

 

Once you have the latest version installed, you will find it as "Autoplay on other devices" in the Settings menu and it will apply globally for connected devices and the web player. 

 

Note that you will need to log in and toggle the setting on or off on either the PC/Mac or Smartphone apps, but once done you can continue using Spotify on whichever platform you prefer and the setting you chose will be reflected accurately.

 

Once again, thanks for helping us make Spotify better, by participating here on the Community.

Comments
FlashyPaladin

Why is this a thing?????? If there’s any device I want it turned off on, it’s the device I’m playing music on when I’m going to sleep or trying to. But I literally cannot turn it off on the google devices.

sodita

Good to see the devs have acknowledged this ticket and that the desktop app solution appears to be working. Something to work with ✌️

Jjjjjjjjs

Is there a timeline for when this is coming to app? Who uses desktop these days... 

zumdar

what the fricking **bleep**. everything was working so well on the web player and then as of today it seems Spotify has decided it is time to autoplay whatever insanity they think will go well with the album i just listened to. Why do these companies do this. I dont want to download your terrible software. I use the web browser version. I feel like this is a stupid ploy to get us to switch to desktop version. Looks like they made all the icons like rounder or something too. very worthwhile 'update' making things more frustrating to use. 

Eni
Status changed to: Implemented

Updated on 2022-02-04

Hey folks,

 

Thanks for coming to the Spotify Idea Exchange and voting to make this happen.

 

We're happy to announce that the option to manage Autoplay has been released for the desktop and now for the mobile app too.

 

Once you have the latest version installed, you will find it as "Autoplay on other devices" in the Settings menu and it will apply globally for connected devices and the web player. 

 

Note that you will need to log in and toggle the setting on or off on either the PC/Mac or Smartphone apps, but once done you can continue using Spotify on whichever platform you prefer and the setting you chose will be reflected accurately.

 

Once again, thanks for helping us make Spotify better, by participating here on the Community.

Chimewave

We're happy too! 

DipDipDipam

3 months, 8 days, 21 hours and 22 minutes to get it done though

shutter41

The fact that there's no way to turn this off for the web app and Sonos is driving me insane. Between this and Spotify's general refusal to be responsive to user feedback, I expect I'll be canceling soon unless things improve.

Jeremy

Hi there @shutter41,

 

Thank you for your reply in this thread. We'd like to explain how this works to you.

 

We can confirm that the setting to control Autoplay behavior on all platforms, including the Web Player is now rolled out to the desktop and mobile apps.

 

Activating the setting will require the installation of one of these apps, logging in and toggling it on/off once.

 

After you're done you should be able to continuing using Spotify on whichever platform you prefer.

 

We hope that this information was helpful 🙂

Take care!