Help Wizard

Step 1

NEXT STEP

FAQs

Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...

VIEW ALL

Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...

VIEW ALL

Enable Web Player in Chrome

Enable Web Player in Chrome

Since last week, anytime I go to open.spotify all it says is "Enable player in your browser" and links me to a very unhelpful site to allow protected content which I have always had on. 

Is there another solution for this? I tried clearing browsing history, cookies etc. but that didnt work. Restarted the comp, still nothing.

Please help!

 

Plan

Premium

Country

US 

Reply
1 Reply

Hey @austinpb94, help's here. 

 

First, make sure that your Chrome is up-to-date, and then try opening the Web Player in an incognito window.


It's also a good idea to enable full functionality on the site settings. Check the settings of your browser to make sure everything looks alright and enabled, such as ads and pop-ups, and that nothing is blocked for the Web player.

Make sure to check out any firewall settings so that Spotify is allowed as well.

If you can, switch network connections and see if that helps. Restart the router if necessary.

 

Lastly, if you're using Spotify between company walls, make sure to check with your IT department. 

 

Let us know how it goes 🙂

 

Suggested posts