Enable secure playback in your browser

Reply

Enable secure playback in your browser

WolfieeifloW
Regular

Plan

Free

Country

Canada

Device

Windows PC using Chrome browser (Windows and Chrome both fully updated)

Operating System

Windows 8.1 Pro

My Question or Issue

When I try to go to https://open.spotify.com/collection/playlists I get the error "Enable secure playback in your browser". I tried using @SpotifyCares on Twitter but they have been no help. I've tried different browsers and clearing cache/cookies. I do not have the option to try a different network or reset the router.

22 Replies

Bethany_Dawn
Community Legend

Hi there @WolfieeifloW ! 🙂
Sorry to hear this is happening - hopefully it will be resolved for you shortly!
I'm just curious if this solution has been tried yet in your troubleshooting?
Feel free to reply to this thread with any updates and I'll see what else I can suggest. 🙂

WolfieeifloW
Regular

I have already done those steps, nothings changed.

Bethany_Dawn
Community Legend

Hi again @WolfieeifloW and thanks for your patience while I looked into some more options. 🙂
There is a similar thread here that has a suggestion in case it hasn't already been ruled out for you. 
Also, I was wondering if you have tried the Firefox browser as well?

Keep me posted and I'll be happy to do what I can! 🙂

WolfieeifloW
Regular

I'm not using a Chromebook or ChromeOS.

 

It does work in Firefox now (it didn't when the issue started on Friday) but this is not a satisfactory solution.

I should not have to run two browsers just to listen to my songs.

Bethany_Dawn
Community Legend

Hi @WolfieeifloW !
Thanks again for your patience and the new info. 🙂 I can totally understand having two browsers open is not ideal.
I'd like to see if there's a few more options we could rule out ...
Have you already tried an incognito session in Chrome to see if it plays?
If so, and there was no change, are you able to provide the version of Chrome you are running? If you are comfortable sharing a screenshot of your settings in the browser as well that would be very helpful. 🙂
You could also try clearing the cache for over a month and see if that makes any difference in the meantime.
Thanks and I'll be happy to help assist more if I can! 🙂

 

HitrecD
Casual Listener

Hello,

 

I have exactly the same problem since last week.

 

Here is my chrome info (sorry for the language).

 

HitrecD_0-1574271369798.png

waassssuupppp
Visitor
I have this same issue. Whatever spotify is doing it is rediculous. I have a not so old version of Firefox that my company makes us use and it doesnt work in there either. Its only version 67 and spotify says its too old. Bullocks!
Also my chrome is the latest and greatest and your how to needs to be updated. The info is no longer valid. This is the link to get to the settings and nothing helps.
chrome://settings/content/protectedContent?search=protected
What is the deal?

Bethany_Dawn
Community Legend

Hi @waassssuupppp & @HitrecD ! 🙂

Would you mind confirming a couple things so this can be looked into further?

1. Are you on a home private network or are you trying to connect through a company/school/public service? If not a private, personal network, it might be due to their system admin settings.
2. Are you able to test it on a different connection - such as a mobile hotspot or another wifi network and see if it still occurs?
Any other data you'd like to share would be great and I'll do my best to assist.

Thanks! 🙂

WolfieeifloW
Regular

Honestly I've just given up on Spotify at this point. Nothing on my side has changed since it was working, it is something wrong with Spotify. I've been in contact with them via Twitter AND email for near a week now with no solution.

 

This is the absolute worst customer support I've ever seen by a professional big name corporation and they should be ashamed, honestly.

HitrecD
Casual Listener
Hi,

1. I am on a home cable network. I also tried it on my laptop (wireless but same network). Nothing works.

2. It works on my Android phone, but won't work with a hotspot.

As I said, it all used to work normally until maybe 10 days ago. So I think it is clearly an update issue.

Bethany_Dawn
Community Legend

Hi again @HitrecD @waassssuupppp  and @WolfieeifloW 🙂
A couple other suggestions/questions - 
1. Are you able to download and use the desktop app?
2. If all previous suggestions have been tried and were ineffective - it sounds like this is only isolated to Chrome and not a network setting.
Have you tried doing a fresh install of the browser already? It would be worth a shot if not. You can find Google's page to do so here.

On another note that might seem irrelevant, I have seen some Chrome errors clear up by enabling Flash again if it was automatically disabled. It's a wild guess, but could be worth eliminating. 
1. Click the padlock at the top of the browser bar when the webplayer is open
2. Under "Flash" it will show your default > set to Allow


Also just for reference, the laptop I'm on at the moment is running the webplayer on Windows 10 with Chrome version 78.0.3904.97 (32 bit). I am also able to run the webplayer on my iMac Catalina OS with Chrome (64-bit)
I noticed in your screenshot @HitrecD your edition is 64 bit. 
If you are able to try it on a 32 bit, that could also be worth testing out to see if it makes a difference.

Thank you all for your patience and feel free to keep me posted with any steps you've all already tried and I will continue to help troubleshoot as I can! 🙂

1.JPG
2.JPG

Nicknomo
Casual Listener

The same thing happened to me this week, but it seems related to the recent Windows update.  Either the November Cumulative update for Windows 10, or the 1909 upgrade seems to have caused an issue.  I'm the IT manager for a medium sized businesses, and I had users complain of this issue.  I initially had the same chrome version as them (latest stable release as of last Friday), and was able to access fine. 

 

The only difference is that they had the latest Win 10 1903 updates applied, and updated to version 1909.  My computer was still on v1903, and had not processed the updates yet.  Over the weekend, the updates were applied to me, and now I can no longer open the spotify web player either. I'm pretty sure its related. In my org, I can't find a computer that can open spotify on chrome now...

WolfieeifloW
Regular

None of these posted solutions have worked.

Now two weeks without being able to use Spotify in Chrome.

Nicknomo
Casual Listener

I'm surprised this isn't getting more attention..

MarkRowden
Casual Listener

Yeah, where is this?

laplasz
Newbie

Same problem here - any idea? on firefox it is working, on chrome - does not

tentakle
Visitor

Nicknomo
Casual Listener

Ok, so I have a solution that worked for me.  It looks like the problem is widevine. For some reason after the OS upgrade to Win 10 v1909, the widevine chrome component did not work.

Assuming you are on Windows,
1) Close Chrome if it is running

 

2) go to 
%LOCALAPPDATA%\Google\Chrome\User Data

 

3) Rename the Widevinecdm to something else.  You could just delete it, but renaming is a less destructive action

4) Open Chrome and in the address bar type Chrome://components

5) Find Widevine Content Decryption Module, then click update.

NOTE: if you had not closed chrome before deleting/renaming the folder, it won't update.  If this happens, try closing and launching chrome and repeating the steps from step 4.  If updating works, you should have a new Widevinecdm folder in %LOCALAPPDATA%\Google\Chrome\User Data

It worked again after I did this.

I would also like to say that technical support for spotify is a joke.  They didn't even attempt to help, only cite reasons why they couldn't be bothered.

d0ri0
Newbie
Nice, worked for me.. However i had to delete the folder located in "\AppData\Roaming\Google\Chrome\User Data"
SUGGESTED POSTS