Help Wizard

Step 1


No playlists on Squeezebox Touch


No playlists on Squeezebox Touch

Because of some issues with die official Spotify plugin on the Squeezebox Touch I reinstalled it. After that, it does not show playlists anymore. I am able to search for songs and play them, but none of my lists is shown.


Accepted Solutions
Marked as solution

Hey guys, I've just merged a couple threads on this issue together. 


Thanks for flagging this with us. We've let the right folks know and we'll keep you updated here. 

View solution in original post

Marked as solution

Mine is now working on the Squeezebox Radio.


This is what I did:


1 - logged into the box by installing the media server and then going to localhost http://localhost:9000/

2- installed Spotify 3rd Party plugin

3 - set settings for plugin (username and password)

4 - opened up port 9005 on router

5 - changed password on spotify for account

6- removed account from box, re added using new password

7 - everything appeared again!

View solution in original post

71 Replies



I use the Spotify app on a squeezebox touch, since earlier today 99% of my playlists have gone (empty)? Although stragely a few still remain and work?


I also use the touch to access audio files on my Synology DS213J NAS and today updated to the latest Synology software (5) as well as updating to logitech media server 7.7.3. Is this the cause? Should this affect Spotify?


Any ideas?





Since yesterday evening I have the same problem with my Squeezebox (not a 'touch' one), without reinstalling anything. Hopefully there is a quick solution! Thank you in advance

Sorry to hear you're having trouble with Squeezebox touch.


Let's try removing and readding the app. 


Let us know how it went.


Fingers crossed!



Having the same problem starting last night.

I am also having problems on my Squeezebox radio. My playlists aren't updating (I add new playlists and they don't show up on the Squeezebox or in Logitech Media Server, running on my QNAP NAS) and when I select any of the exisiting playlists (either on the Squeezebox or in LMS) I get "502 Bad Gateway".


I'm running LMS 7.7.2.


UPDATE: I just tried switching the Squeezebox over to use, then rebooted it. The problem remains the same - no new playlists and the existing ones give "502 Bad Gateway"


I should also add that I've tried reinstalling the spotify app within LMS, as well as restarting LMS itself - it makes no difference.

I get the '502 bad gateway' anouncement too, in the 'with star' section.

I can not see any playlist at all. 

I'm having the same problems with the Squeezebox App.  I get my account name coming up on the Spotify App Menu, and can search, but all my playlists have gone.  Please help.

Have the same problems. Can search online on spotify but no playlists are available. Just on the squeezebox radio, on Spotify App for Mac all works fine. On Spotify App (Android Phone) works fine too.

On Squeezebox Radio and on Apps for Android or iPad (Remote Squeezebox) no Playlists.

I Have 2 Squeezebox Radios and a few days before all works fine.

sorry for my poor english.

Thanks for the reply I hope you can help.


After removing and reinstalling the app the problem continues.


It's odd as just about all the playlists are not listed as text just a musical symbol, if I access them it usually states that it is 'empty', although quite a few are now saying 502 Bad Gateway.

Strangely one of the playlists that was initially blank I was able to play.


The starred tracks I am able to play also! If I want to star a track it doesn't appear on the squeezebox touch but does on my laptop and my iphone!


If I unplug the touch and plug it back in - sometimes all the playlists are listed but are unplayable either as 'empty' or '502 Bad Gateway'.


Even more oddly there are 6 or 7 playlists that play fine. 


So some things like the starred tracks work fine so Spotify must work, but there must be something preventing it from being fully acessible. Surely it must be the latest update on my NAS or the Logitech media software 7.7.3 disrupting it?


The touch caters for most of my music listening at home, without the Spotify app working correctly on the touch (which I play through a stereo system) Spotify is virtually useless to me.




I have the same problem with my squeezebox radio (now UE smart radio). I don't see any playlists, and when I enter starred tracks, I get "502 Bad Gateway". What is happening? Uninstallig the app and doing the fatory reset didn't help.

Same problem here. No playlists on Squeezebox, but I can use the search function. Factory reset and reinstalling the app didn't help.

I've raised this as an issue to the Spotify guys since there are multiple reports here on the community.

Spotify Community Mentor and Troubleshooter

Spotify Last.FM Twitter LinkedIn Meet Peter Rock Star Jam 2014

If this post was helpful, please add kudos below!

Thank you.

Thats good Spotify are aware there is a problem but when will the paid for service return?

I still have an unusable spotify app.

Please let us know asap.


Having the problem with my smart radio.

I do have the same problem in Belgium on a Squeezebox Touch.
Opening the star-songs (favourites) gives a 502 Bad Gateway.
My playlists aren't loading neither.

I have reinstalled my server, have done a factory reset, reinstalled the Spotify plugin, etc...
Nothing didn't work... !!!


I don't know anymore what I can try else?

That's exactly happened to me, however i haven't got any playlists at all and I can confirm that this happened before the squeezebox update.

Ditto.  Started on Sunday 3/23.  I no longer see my playlist.  I can search and play music but my playlists no longer load.  Also get the gateway error.  Spotify, are you working on this issue?  

Is Spotify working on this problem?


I see there are many others on other threads with the same problem, these threads need to be unified and made sticky?


It has been three days now and I haven't beeen able to access my playlists.

They are not being updated either, some I have deleted are still there and some I have created have not appeared.


Is this being dealt with?


I also keep an eye on this topic:

So far also no solution there..

Suggested posts