Sony 2015 receivers dropped Spotify Connect

Solved!
Reply

Sony 2015 receivers dropped Spotify Connect

Domewodka
Music Fan

Sony just confirmed to me that their 2015 line-up of receivers, do not support Spotify Connect, even while all specification sheets do mention it being supported. Too bad I already bought myself a STR-DN1060.

 

So the only option I now have is Google Cast. But that will not be supported by Spotify because of Spotify Connect. How stupid is that?

1 ACCEPTED SOLUTION

Accepted Solutions
Solution!

tweety2b
Regular

Hi,

 

I double checked your statement with our European Audio product team and it is not correct. This is the info they provided me:

 

The STR-DN1060 AV Receiver belongs to a family of audio products from Sony that are all compatible with Spotify Connect. An automatic firmware update will be provided that will allow access to Spotify Connect. The firmware update timing varies by product and the schedule is as follows: 

STR-DN1060 and STR-DN860 AV Receivers, HT-XT3 Sound Base, HT-ST9 and HT-NT3 Sound Bars : 20th June 2015

SRS-X99, SRS-X88 and SRS- X77 Wireless Speakers : 15th June 2015

 

I hope this clarifies for everybody. For any further Sony product specific questions you are always free to ask it here

 

In the meantime if you could let me know who gave you that information, I can make sure that such wrong information is not being distributed.

 

Kindest regards,

Nico

 

Nico Henderijckx

Head of Communities Europe

Sony Europe LTD

View solution in original post

55 Replies
Solution!

tweety2b
Regular

Hi,

 

I double checked your statement with our European Audio product team and it is not correct. This is the info they provided me:

 

The STR-DN1060 AV Receiver belongs to a family of audio products from Sony that are all compatible with Spotify Connect. An automatic firmware update will be provided that will allow access to Spotify Connect. The firmware update timing varies by product and the schedule is as follows: 

STR-DN1060 and STR-DN860 AV Receivers, HT-XT3 Sound Base, HT-ST9 and HT-NT3 Sound Bars : 20th June 2015

SRS-X99, SRS-X88 and SRS- X77 Wireless Speakers : 15th June 2015

 

I hope this clarifies for everybody. For any further Sony product specific questions you are always free to ask it here

 

In the meantime if you could let me know who gave you that information, I can make sure that such wrong information is not being distributed.

 

Kindest regards,

Nico

 

Nico Henderijckx

Head of Communities Europe

Sony Europe LTD

View solution in original post

Domewodka
Music Fan
Hi Nico,

Thanks for your reply. The answer was given twice by the EU customer support, in Dutch, case number 12684446.

Very happy to hear a fw update will arrive soon!

Kind regards,
Rik

emtrane
Newbie
I'm being very impatient here but it's the 20th of June and I don't see the firmware update yet. Any news?

tweety2b
Regular

Hi,

 

I checked internally and we experienced an upload issue during the weekend uploading the new firmware on the download server.

The engineering team will try again today so hopefully it will appear for you to download by tomorrow.

 

Please confirm tomorrow if you can see it.


Cheers

Nico

 

Head of Communities Europe

Sony Europe LTD.

Rizzer
Gig Goer

Thanks for being active on this question, Nico.  It gives us confidence in a company when they engage with customers like this (and not all of your competitors do). We don't  need to always know everything's perfect, we just need to know our worries are taken seriously.

 

Looking forward to the coming update.

Domewodka
Music Fan

I checked manually and indeed the 1060 found a update. Installed it immediately.

 

Now Spotify indeed says there is a new Spotify Connect device available: the 1060. However, it fails to connect to it :X

 

Spotify Android (beta) ---> Spotify Workstation       works fine

Spotify Android (beta) ---> Sony 1060                      detects but fails playing

Spotify Workstation      ---> Sony 1060                      detects but fails playing

 

Tried cycling power but it didn't work.

3beat
Newbie
I've installed an update on 1060 and spotify connect works very well. Phone - xperia z1.

Rizzer
Gig Goer

My DN1060 picked up the update.  Spotify Connect is now there, my Android Spotify app could immediately see the device and connect to it.  (Domewodka, you said you used the Android beta app. Why not use the current full version instead of the beta?)

 

It sort of works fine but there are a couple of wobbly issues. 

 

At first the songs stuttered a lot while streaming. I seemed to have fixed that up by rebooting all the devices along the chain, the phone, receiver and router.

 

Now it starts playing a song well enough. But then it just stops after 30 sec or so.  When I look at the Android app I see the song is paused for some reason.  I don't know for sure whether its the app or the DN1060, but the app didn't do that when I connected to the receiver via bluetooth rather than Spotify Connect. The problem seems to affect the first one or two songs I try to play. When I change songs, it eventually seems to wake up and stops falling asleep like this.

Rizzer
Gig Goer
I think my sleeping app problem must have been the phone not the DN1060. I switched the phone off. When it rebooted it reported "applying Android updates". Very thoughtful of it to tell me earlier that it had some updates to apply 😞

The Spotify Connection between phone and DN1060 is proving to be perfectly fine now after that.

tweety2b
Regular
Great to hear it isn't the receiver. I had passed the info to Japan and was awaiting a conclusion but will let them know they can close the case. Have a great weekend, Nico

Rizzer
Gig Goer
Thanks Nico. Better keep the case open though, or at least tell them to keep an eye on it. The problem is back today. I can't think of any good reason why. I guess it must be some problem in Android or in the Spotify Android app, but it'll impact on people's impressions of the Sony receiver. Maybe I can clear it out by rebooting the phone, but it's not so convenient to have to reboot every time I want to put music on. It's a Sony phone by the way, Xperia Z3 compact.

Rizzer
Gig Goer
Worse news: further testing suggests it might be the DN1060 after all. I rebooted phone but now the problem keeps happening anyway.

Spotify now appears in Music Services alongside Google cast. I can control the Spotify song directly with the DN1060 remote (play, last/next song). In fact I can continue to control it even after I switch off the phone, the playlist is still accessible. When I do that, playing Spotify direct on the DN1060 without the phone, I get the same problem: it plays for 50 sec and then stops.

But now the DN1060 gives a warning before it stops: "This device is not connected to network." But the network connection is fine as far as I can tell.

Restarting the DN1060 with its on/off switch didn't help. But, finally, power cycling from the power point has now fixed it again. I'll report back if it stays fixed this time.

tweety2b
Regular

Hi Rizzer,

 

😞 I will let Japan know. Hopefully I will get some answer back shortly.

 

Cheers

Nico

 

Head of Communities

Sony Europe LTD.

Rizzer
Gig Goer

Sadly it's still misbehaving again today.  A full power cycle restores it again.  At least it's not too much trouble to power-cycle the receiver.

Azhag
Regular

I'm adding myself to the list of DN1060 owners with Spotify Connect not working...

 

I cannot even get it to work after a reboot. Starting Spotify from Music Services shows me something, but then after a long time waiting, it says "The device is not connected to the network".

I can see the receiver in the Spotify Connect list on my phone, but trying to connect to it doesn't do anything.

 

Additional question:

are we supposed to be able to see the receiver as a Spotify Connect device target all the time (e.g. when the receiver is on another input), or only when opening the Spotify app?

(the latter would be quite disappointing, I'd like to be able to start sending music without tinkering with the amp)

 

Happy to help debug or test more if that helps.

Azhag
Regular

All right, so new information that might help some of you:

 

All my issues with the Receiver disappeared when I moved to a wired Ethernet connection, instead of Wifi as before.

I can now see the Spotify Connect target, and it connects directly, smoothly and works fine.

 

This is a bit disappointing from Sony, but here you go, avoiding Wifi solved it for me, let's see if this holds up...

Rizzer
Gig Goer
True, my connection is Wi-Fi.

Domewodka
Music Fan
I'm using a 1gbit cable connection, still not working. Subnet is the same.

Domewodka
Music Fan
OK, got it working for the first time, finally. I changed the Sony 1060 it's name tot "Sony" instead of "Sony 1060", expecting it could have something to do with the space in the name. And BAM, it works.

I guess Spotify needs to put in some quotes when connecting to the device_name, or find a different way to handle the space char.
SUGGESTED POSTS