Announcements

Spotify on Chrome OS - Error 502 and 504 when launching web player

Solved!

Spotify on Chrome OS - Error 502 and 504 when launching web player

Hi guys, 
So this is something I've not experienced before - I was very happy with the spotify web player version and using it with Chrome OS after paying for the 3 months premium deal. Shortly after, every time I try and launch play.spotify.com it comes up with either error 504 or 502. I've got no idea how to get around this, I've tried restarting and reinstalling the launch app in Chrome OS but nothing seems to work. It may help if I add that my spotify account works on all my other devices as well as on other computers. It's just mine that seems to be the problem. Any help would be appreciated - Thanks!
Michael.



Additional Information:
Latest Chrome OS software, HP 11-2000na chromebook



Reply

Accepted Solutions
Marked as solution

Seems they (spotify?) fixed the problem. Webplayer works fine again.

View solution in original post

10 Replies

got the same issue cannot access except the stupid mobile app ... please helllllllllllllllpppppppppp 

Same here. Spotify webplayer generates 504 error from chrome OS. No Problem with other devices.

Same problem for me as well this morning, really annoying!

The same message is coming up when I use Safari so must be a deeper problem, hopefully will get fixed soon.

Same Issue here (504 Gateway Time-out), just seeing the default nginx server error page.

 

Chrome on Windows 7 btw, so a spotify server issue rather than an OS or browser one I think.

Fixing 504 errors - general

This problem is entirely due to slow IP communication between back-end computers, possibly including the Web server. Only the people who set up the network at the site which hosts the Web server can fix this problem.

 

i.e. it's a Spotify end problem.

Marked as solution

Seems they (spotify?) fixed the problem. Webplayer works fine again.

Yep, appears to be fixed for me now too. Well done Spotify

Wednesday Jan 12 - I having  this same issue, so its not fixed completely.

Same Issue here (504 Gateway Time-out), just seeing the default nginx server error page whit Chromebook and windwos

Suggested posts