Help Wizard

Step 1



Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...


Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...


Spotify stopped working on Amazon echo 4th Gen, can't find device anymore

Spotify stopped working on Amazon echo 4th Gen, can't find device anymore






Amazon Echo (4th Gen) 


I've recently bought an Amazon echo (4th Gen) and 2 echo dots (3rd Gen) for my home. Upon setting it up, Spotify worked perfectly in all of then. A few days later, however, the echo 4th Gen was unavailable in the device list while the other 2 worked just fine. Since then, I've been trying to make Spotify reconnect to it again, with no success. 


Things I've tried so far, gathered from a few responses to similar issues:


- Make Spotify forget the unavailable device 

- Unlink and relink the Alexa and Spotify accounts

- Remove the Spotify skill from Alexa and install it again

- Clean reinstall the Alexa and Spotify apps

- Revoke Alexa access to my Spotify account and granting it again

- Fiddled with the "find only local devices" option in Spotify app 

- Switched wifi network of all devices

- Factory reset the 4th Gen echo and set it up again

- Double checked if firmware was up to date

- All of the above togheter 


Nothing worked.


When I ask the problematic echo device to play some music on Spotify, it finds the correct artist/playlist I'm looking for, so it definetely has access to my account. It then responds that it will play, but no sound comes out. If I start playing in one of the 3rd Gen echo devices, it has no problem, and when I try to switch the device via the Alexa app it freezes for an instant, as if it errored, and then stops playing. Switching between the 3rd Gen echo dots via the Spotify app works fine, but the 4th Gen echo simply does not appear in that list.


Also, the weirdest thing is: Alexa has a default group "everywhere", which contains the 3 echo devices. If I ask Alexa to play music everywhere. It plays on the 3 devices, since this group is listed as a single device in the Spotify app. It plays perfectly fine in the device that it can not find alone.


Also, I'm pretty positive this issue is on Spotify side, since every other Alexa function works fine, even Amazon music plays without any problem. 


At this point I have no idea what to do anymore, any help would be appreciated. 

130 Replies


Premium Family 




Amazon Echo Dot 4th Generation 


My Question or Issue 

Hey there, I've been having trouble with the /v1/me/player/devices endpoint. For some reason, all of the Amazon 4th Gen Echo Dot devices (and exclusively these devices) just stop being retrieved after some time.  

I did, however, notice that it's possible to use these devices via Connect on the Spotify app just fine (or on the web and desktop players, for that matter), which makes me think that this issue might be strictly API-related.  

Furthermore, I've also noticed that it's only after using the Spotify app and opening the device selection screen that the API starts retrieving the 4th Gen Echo Dot devices correctly.  

It's almost as if checking the user's available devices through the app emits a 'wake up' signal to the Echo Dot devices and only then makes them responsive to the API sweep. Is there such a thing?  

(Goes without saying, but I did try restarting the devices, linking and unlinking accounts, checking the firmware version, etc.). 

Thanks in advance! 

Hi, sorry for bumping this, but it seems that the issue is still occurring and unfortunately we haven't been able to figure it out. Would appreciate some help, thanks.

Hi, thanks for responding so quickly. I did check the topic, and while these issues (mine and theirs) might be related (in the sense that both refer specifically to the /player/devices endpoint), the issue I'm facing right now seems to be specifically pertinent to the 4th Generation Echo Dot, whereas the issue reported in the topic you mentioned seems to happen with any Echo Dot that has had its firmware updated.
Besides, the behavior reported at that topic seems to be slightly different from what I've been experiencing with the 4th Generation Echo Dot: instead of displaying the "weird" serial number as they've mentioned over there, my devices are simply not being retrieved.

Are there any solutions?

what does the Spotify customer service say?


Same issue over here. Thought I was going a bit mad until I found this thread. I have fourth gens and they keep disappearing. When I get them to register again they have UUIDs for names.

I'm just wondering how long it will take Spotify to fix this **bleep**

the problem has been known for 6 months.

that's just annoying

Bumping to signal that we're looking into the issue. I'll post updated here as soon as we learn more.

The same thing reported by Stephan73 in the other thread happened to me now. I left the device powered off over the weekend and got the same response by the API when I tried getting the available devices this morning: even while offline (powered off), the device was still being retrieved and listed as if it were online and available.

Evidently some changes must've happened, since the previous behavior (device not being retrieved after a couple minutes) is not being shown anymore.


Moreso, I've also noticed that even if the device is powered on, I always get a 404 when trying to transfer the playback through the (...)/me/player endpoint (after 10 minutes or so of not playing anything in said device). So, the only difference really is the fact that now the device is always being listed by the API call, but still doesn't really work regardless.


This makes me wonder, do you mind giving us an update? Is this new behavior in any way an indication that you guys are trying to work around the issue presented here in this thread or is this an entirely new thing (bug)?

As you've noticed by the change in API behaviour, we are working on this issue and trying to get to the bottom of it. We identified and fixed some of the trouble, but it turns out to only be a part of a bigger puzzle that we're still investigating. 


I'll circle back when we have news.

Very happy to hear that. And you taking the time to keep us posted is sincerely very much appreciated.

If you don't mind, I plan on bumping this thread sporadically, no spamming, just to make sure that enough people are aware of this issue's current status. I say this because I think we can agree that a fair amount of users have been experiencing this problem for a while now and, like me, they eventually think about resorting to this board.

Any news? This is an issue isnce the echo 4 was released. Really annoying unfortunately 😕

This is exactly what is happening to my spotify with alexa! 

Same with me , the very same , wish I never bought the 4th Gen now !! 

Hey folks,


Thank you for reaching out to the Community and welcome.


@danilofrp, that's a great troubleshooting done so far, thanks for sharing this info. However, we'll need more information to keep investigating this.


Could you confirm if this issue started after an OS update of your Echo or any Spotify update?


Also, to make sure it's not a batch of accounts affected, would you mind trying to use a different Spotify account logged to your devices, - such as a friend or a family member, to see if the issue persists?


If so, check if the 4th gen Echo is shown in the available devices using that account, and ideally, from another phone.


Lastly, @Pinksucrose and @TippyTongs100, would you mind sharing the troubleshooting you've done so far?


We appreciate your report and cooperation. We'll be on the lookout.

Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

This is happening to me too. I've tried all the same troubleshooting that you have, I've tried accessing through 4 different Spotify accounts and it just comes up with "Cant play on this device" . When I ask Alexa " play Spotify" she responds with the track I have open in the app, but nothing happens. 

Hey there,


Thanks for the replies and the troubleshooting steps you've tried.


Could you try and reset the external speaker to its factory settings? This will exclude the possibility, that the issue is related to a recent update of the device's firmware.


Also make sure, that the Spotify account and the Amazon account have the same country settings.


Let us know how that went,



Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.

Hello, I have the same problem in Germany as well. Amazon customer service doesn't know what to do either, even replacing my device didn't bring any improvement. The problem is now so present that Amazon and Spotify have to work on a solution.

Hey @BR408,


Thanks for getting in touch about this here in the Community.


Could you let us know which troubleshooting steps you've already tried? That way we can avoid any repeating steps.


We'll be on the lookout.

Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
“Music acts like a magic key, to which the most tightly closed heart opens.”– Maria von Trapp

Suggested posts