Announcements

Web player recaptcha / screen loading error

Solved!

Web player recaptcha / screen loading error

sikknote

Note: forum directs me here for web player issues but there's no Web Player 'label', apologies if posted in wrong place

 

Plan - Premium

Country - UK

Device- Windows 10 Laptop / Chrome (Web Player)

My Question or Issue

I 'pin' the web player in chrome. When i load it initially, it's fine; when i browse back to it, the screen has gone wrong, and displays

"Could not connect to the reCAPTCHA service. Please check your internet connection and reload to get a reCAPTCHA challenge."

SpotifyError.PNG

Reply

Accepted Solutions
Marked as solution

EthanS1

@blank5 wrote:

I am having the same problem. I am using Chrome 84.0.4147.89 and it it showing up in a pinned open.spotify.com window.


Hey all, 

 

I hope your having a lovely weekend, just a follow up on this. If Spotify is pinned to your chrome could you attempt to unpin the web player, restart Chrome and pin it again? 

 

Thanks for keeping me in the loop, I've passed this across to the right teams and we're trying to work out what's causing this.

 

Have a great weekend! 🙂

 

View solution in original post

46 Replies

faicbeag

I tried clearing cache & cookies, but when I tried to log in again it failed silently, did nothing for about 45sec, and then eventually displayed the "could not connect to recaptcha" message. I called support, they said uninstall chrome, reboot, then reinstall chrome, and that let me log in, but the error still pops up to the left of the web player for me just like you.  Win7

katezaitseva1

Have the same problem in Google Chrome, clear cache but the problem hasn't disappear

EthanS1

Hey guys!

 

Thanks for the reports so far, I've tried to replicate this however so far I haven't been able to could you try a different browser and incognito window and let me know how those go?

 

If not, I'll try and find out what seems to be happening here, in order for me to get this across to the right people could you let me know:

 

  • Country
  • Browser Tried
  • Device
  • Steps to re-produce 
  • Any other screenshots you have of this (without any personal info!)

Standing by,

faicbeag

UK

Chrome 84.0.4147.125

Desktop PC, Win 7

No specific steps, it just appears on the web client


Strangely, the message did not appear at all yesterday, and is back again today.  Nothing changed at my end in this time, which suggests to me that the issue is at Spotify's end.

Also I can't seem to post a reply to this page. I am now trying through incognito mode after 7-8 failed attempts - I think the same captcha issue may obtain here.

Spotify 2.PNG
Spotify.PNG

bdvandewater

Hi Ethan,

 

Thanks for looking into this! Here are my details:

  • USA
  • Google Chrome, Version 84.0.4147.105 (Official Build) (64-bit)
  • Mac, OSX Mojave 10.14.6
  • Steps:
    • Opened WebPlayer in pinned tab

It seems to be behaving today... I could not reproduce it.

 

Thanks!

EthanS1
Hey!

Thanks, a lot of updates I’ve had so far from you guys is that the issues has rectified itself, it seems it potentially was a temporary error which has been fixed as soon as it’s been identified.

I’ll keep an eye on this thread over the next week if you see this return again let me know and I’ll escalate this further otherwise enjoy the rest of the week

cowst

I never stopped having this issue.

It doesn't seem to happen on Chrome in incognito mode, but normal Chrome doesn't even allow the login after clearing cookies and data.

In console I see:

 

Refused to load the image 'https://www.google.de/ads/ga-audiences?<rest of url>' because it violates the following Content Security Policy directive: "img-src 'self' https://i.imgur.com https://d2mv8tnci56s9d.cloudfront.net https://profile-images.scdn.co https://*.scdn.co https://graph.facebook.com https://fbcdn-profile-a.akamaihd.net https://*.fbcdn.net https://platform-lookaside.fbsbx.com https://www.google.com https://www.google-analytics.com https://stats.g.doubleclick.net data: https://accounts.scdn.co".

katezaitseva1

Sorry but I've never stopped to have this behaviour of Spotify too, today opened it in the pin bar and got the same

katezaitseva1_0-1597660574982.png

 My characteristics:

Russia

Google Chrome Version 84.0.4147.125 (Official Build) (64-bit)
macOS Catalina Version 10.15.5

Steps:
Us usual opened WebPlayer in a pinned tab
When I update it, got the same
 
I've tried to reinstall Google Chrome, didn't help

EthanS1
Thanks both,
Some others reached out to me directly to let me know they weren't having further issue. I have escalated this to the team at Spotify any updates I'll feed in as soon as possible.

sikknote

I can confirm that this isn't happening for me anymore - thanks to whoever fixed it, however they fixed it... and sympathies to those who are still seeing it!

EthanS1

Hi All,

 

I've checked this out with some of the teams at Spotify and let's try some further steps and I'll report back what we find. It seems the majority of reports are in Chrome so I'll outline some steps below to try

 

  1. Firstly, could you check in your Chrome Settings “Allow site to play protected content.” enabled You can do this by: Chrome > At the top right, click the : >  Settings. > Under "Privacy and security," click Site settings. > Click Protected Content. > Turn on Allow sites to play protected content - Then restart your entire PC and then see if the issue persists.
  2. If it is still persisting, could you try another browser - If you find the other browser isn't giving this issues, it's potentially a Chrome isolated issue, follow the steps to remove chrome which can be found here and then reinstall Chrome.

 

Keep me in the loop. 

 

faicbeag
Hi Ethan - I spoke to support when this issue first came up. Per their advice, and since the issue did not occur when I tried using IE, I tried reinstalling chrome. This allowed me to log back in again, but the reCaptcha issue soon returned.

Based on the fact that this issue is intermittent (it didn't occur at all for me yesterday, but was there first thing today) without any changes on my end, I would hazard a guess that this issue is server side.

EthanS1
Hey @faicbeag!

Thanks for the reply, I'll report that back to the right folks with the rest of the findings on this. Could you try something specifically, could you try a different Internet Connection if possible and let me know whether we see any change at all?

Will keep you in the loop.

faicbeag
Hi Ethan, sadly I do not have any other available connection to try, no wifi card in my desktop

EthanS1
No worries, I’ll keep you in the loop if I hear anything further, just to confirm did you try the 1st steps in my post today?

faicbeag
Thanks - the protected content thing you mentioned was already set to allow on my machine

EthanS1
Glad to hear, I’ve fed that back and will await an update and looking forward to hearing what the rest of the folks find! 🙂

TimGraffam
Came across this thread after noticing the same issue as originally reported. I've also verified the Chrome setting mentioned previously is already set.

EthanS1

Could you try a different browser @TimGraffam, it seems this is an isolated to Chrome in most reports. It does look like it's more of an issue with Chrome the browser itself overall however I'm still feeding this back for further research.

Thanks,

Suggested posts

Env: prod