Help Wizard

Step 1



Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...


Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...


Update playlist tracks doesn't recognise "uris" parameter

Update playlist tracks doesn't recognise "uris" parameter

I'm trying to update the tracks in a playlist using the playlists/playlist_id/tracks PUT action, as described at

I'm using this curl command, modified from the example given, but with the "uris" parameter instead:

curl --request PUT \
--url '' \
--header 'Authorization: \'Bearer .......\'' \
--header 'Content-Type: application/json' \
--data '{"uris": ["spotify:track:.....", "spotify:track:......"]}'  

I'm getting this response, which doesn't seem to make sense considering the docs:

  "error" : {
    "status" : 400,
    "message" : "Unsupported attribute(s): [uris]"

 The playlist ID and bearer token seem correct, because the GET action returns the current tracks in the playlist.

3 Replies

Hey there, help's here!

Let's have a look at what's happening. It seems that you've added the uris parameter to your request body. Could you try moving it to your request URL?

Your Request URL might look something like this:***PLAYLISTID***/tracks?uris=URI1,URI2

If you need more help on formatting your request in cURL, check this out: 🙂

Let me know how you get on!

Have a great day,

HuboSpotify Star
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

It's been a while since this issue and answer was posted, but with my current application I am working on I am facing the same problem.

I have the error "Unsupported attribute(s): [uris]"

I have tried using a loop to append the uris to the url as a url query, although that returned  "413 Request Entity Too Large"

I tried again, and was then told a second time there was an error parsing JSON. I was not passing any data/json in and only the headers, which I know are not the problem. I am certain my URI was correct, In the format 

?uri=URI1,URI2 etc

What is the problem?

I hope you or somebody else may have the answer, thanks in advance 🙂

@br3ndog The parameter is plural: ?uris=URI1,URI2

Suggested posts