Announcements
Downtime February 23rd: Account page error "Something went wrong. Try again later". Click here for more info.

Help Wizard

Step 1

NEXT STEP

Removing a song opens the edit page again for removed and previously removed songs

Removing a song opens the edit page again for removed and previously removed songs

Plan

Premium

Country

Norway

Device

Huawei P30 Pro

My Question or Issue

When i click the 3 dots/edit and i remove a song from say a playlist i have, the edit page opens again. Ill then have to drag the edit page down or close it. When i remove the 2nd song the edit page opens but after i close it the edit page for song 1 is opened and i have to close that too. then when i close the edit page for song 1 the edit page for song 2 shows up again, hahah, i have to drag or go back out of it and then the edit page for song 1 opens up. when i remove a 3rd song the same process happens but multiplied, which is very annoying and it doesnt make sence. This bug has to be fixed. Ill add 15s video of it under files, i had to compress the video to have it 5Mb, the limit for a file.

Reply
23 Replies

Hey there, welcome to the Spotify Community!

 

Thanks for sharing the screen recording. It helps us take a closer look at what's happening. Is this happening with all playlists or a specific one? 

 

I would also recommend a clean install of the Spotify App. This tends to fix most issues easily. You can read more about how to perform a clean install here.

 

Keep me posted.

AmayySpotify Star
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

I noticed that if i edit a song. Just open the edit page, not removing it, it joins in on the edit pages opening after i delete a song. Its not just the songs i delete, but all songs ive edited during this session. If i go out and in of the playlist it resets but i cant do that every time i delete a song. And the problem is still there because that one song i remove opens again anyways and thats annoying.

 

Not for a specific playlist. It happens in any playlist.

 

I will try a clean install and keep you posted

Thanks for the reply @Chameleon1234. I tried on my end but failed to reproduce this issue.

 

I appreciate that you are trying the clean install process, I will wait for your response with the results.

AmayySpotify Star
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

Thanks for helping me out with this problem, i really need to figure this out.

 

The clean install didnt help tho. Step 7 asked me to delete this spotify file "if" i found it but there was no spotify file like it so i had to skip that step. But other then that the clean install didnt help with the problem.

Thanks for the response @Chameleon1234.

 

Please try these steps and let me know how it goes:

 

  • Log into another account on your device and see if that fixes the issue.
  • Log into your account on another device to confirm the same.

 

This will help me figure out what exactly is causing this issue. Also, let me know your device and app version info.

AmayySpotify Star
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

Plan 

Premium 

 

Country 

United Kingdom  

 

Device 

Huawei Honor 10 Lite 

 

Operating System 

Android 10  

 

My Question or Issue  

When removing a song from a playlist, the menu repeatedly opens on itself. This only happens when removing a song from a playlist and has existed for many updates now.   I've posted on the TrueSpotify Reddit and it seems that the only people who have this problem are Huawei users which I am.   I've used the Spotify support chat. I followed the instructions of reinstalling, clearing cache and doing a clean reinstall. I didn't work. The only fix they had was to install and older version.  

 

I have a link to the issue happening  https://youtube.com/shorts/5AGzaUtov4s?si=4R_focyhr0K2QNiw  

 

Can people confirm that I'm not the only person going through this? This bug is very annoying and I've only encountered 2 other people with this issue and it makes no sense that an issue this obvious is still here after 2 months of updates

Hi, thanks for being patient with me.

The problem only accured on my device, what account was used didnt matter tho.

My device is Huawei P30 Pro.

My app version is 8.8.92.700 

This problem is not solved for me until i can fix this using the newest update. That is very important to me that i can stay on updated app versions. Also, the problem occurs no matter what playlist i remove a song from. The problem started 1-2 months ago, if that helps.

Hey @Chameleon1234,

 

Thank you for keeping us updated.

 

In the video we can see that the music is playing through a Bluetooth device and not directly from your Smartphone. Would you mind confirming if this happens as well playing music directly from your smartphone or not playing tracks at all? 

 

Also, it would be great if you could include in your next response the OS version you're currently running on your device. This will help us investigate this further.

 

We'll be on the lookout.

OscarDCModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Doesnt matter if im on bluetooth or not.

I believe the OS version is : EMUI 12.0.0

Let me know if you guys need more videos or anything, i really hope we can figure it out. I remove a lot of songs all the time, specially when im organizing my playlists

Yes! I have this very annoying problem too!

Exactly the same here!

This issue is so annoying and I'm genuinely super frustrated it hasn't been fixed yet. The only OS I've seen it been affecting is EMUI ones or similar. This has been happening for months now.

 

I just hope that at some point this gets reported enough that Spotify actually notices and attempts to fix it.

 

A small temporary fix I've found is when the menu appears again, click "add to playlist". when the add to playlist menu appears, back out of it. That should stop the menu's multiplying when you remove multiple songs one after another. They still appear, but there will only be 2 of them.

 

This needs to be fixed ASAP with how annoying this bug is

Exactly the same problem as listed by others. 

Guess making £50 million a month stops you from fixing these issues?

Please get it sorted. 

Hi there folks,

 

We've been looking into this on our end but weren't able to find anything so far. So we can investigate this further, please send us the following info:

  • The exact makes, models and OS/Firmware versions of all your affected devices
  • The exact Spotify Versions you use.
  • Screenshots or a video of the behaviour

Thanks in advance!

JoanModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

old screen recording (this was literally from months ago)n- https://youtube.com/shorts/5AGzaUtov4s?si=wDeyz8d0pd-oLi0j

 

Screen recording on latest version - https://youtu.be/R3sd_pkjDcY?si=FOL_45kgshvKRelw

 

 

Huawei Honor 10 Lite

Android 10

 

Spotify version 8.8.96.364

 

This is just embarrassing for Spotify to have this bug for so long. But ofc instead of fixing a broken vital feature, let's change the heart to a plus.

Ive alreadt sent you all this, scroll up, ive had to talk to multiple different moderators here. What information are you missing?

Huawei P30Pro, EMUI 12.0.0

Spotify: 8.8.92.700

I sent a video on the original message here. And other people whos jumped in here has also shared videos of the problem.

So the issue exists also on Honor 90 using Android 13.

Same here, 

 

Huawei P Smart 2019 

Emui 12.0.0

Updated spotify after clean install

For weeks now, please fix this

 

I went back to version 8.8.50.466, where everything behaved normal. Still this ain't the permanent solution, please fix this bug (as documented thoroughly above) 

Suggested posts