Help Wizard

Step 1

NEXT STEP

FAQs

Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...

VIEW ALL

Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...

VIEW ALL

Can't download App

Can't download App

Hiya, just got iPhone 6 and it won't let me download app onto this device, shows the cloud with down arrow but won't download it, have already on iPad and samsung TV so why won't it work on new phone. Thanks
Reply
35 Replies

It sounds like a problem with the app store trying to download the app.

 

Have you tried logging out of the app store and then logging back in?

 

Also try restarting your iPhone.

MattSudaSpotify Star
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

I'm the same too, I get the cloud sign and nothing happens. Restarted it, updated the most recent ISO checked restrictions and nothing. Wouldn't mind but getting free spotify through bloody vodaphone 😜.

Did you find s solution as I have the same problem....

I'm having the same problem here. Any solutions? Thanks!

Same problem here. Any solution?

Hi,

Same issue for me... unable to DL the last update on my iphone6. Cloud icon in appstore on the phone.

Now the icon of Spotify on the phone is the default ios9 icon... can't uninstall.

Restarted the phone, now there is no more Spotify icon .. I retry to re-download it..

 

Edit: Okay, dowload finally completed. Some of my dowloaded album not showing, i saw another thread for that i'm not alone

Having the same prob!

Hi @12128647177

can you please try restarting your device and seeing if that resolves the issue?

Let me know how it goes!

Same problem. Phone has been restarted loads of times. Spotify is no longer on the phone as far as I can see. When I go to the App Store to download it all I see is the cloud icon with the downward facing arrow. If I press that then there's a split second where it looks like it's beginning to download then snaps straight back to the cloud/arrow combo.

Hey @thomasjamesmitc, are you able to download any other apps?

Yep, can download other apps no problem.

Bizarre. Can you try signing out and in again into the App Store? Also, what version of iOS are you running and what device are you using?

I am having the same issue... I have an iPhone 5S

I have the same issue.. (Iphone 5c) when I press the cloud button nothing happens

However now my frustration solved the problem.. After having done all resets I could think of and logged in and out of app store I just pressed the cloud button like 20times and all of a sudden it worked.. Thanks to the monkey method

LOL 

 

I have also was keep pressing the cloud icon and suddently it's just worked. I have tired all the other methods mentioned before too. 

This is happening to me as well

Argh same here! It logged me out this morning and it said online that it was trying to sync to my phone so I deleted it and tried to reinstall. Now not working at all and I don't know how to log out of the App Store 😞

Hey guys, can you try signing out and back into the App Store? If you scroll down to the bottom of the Featured tab, you will see the "Apple ID" box with your email address in it. Tap that, then you can tap Sign Out.

 

Give that a shot and let us know how it goes. Cheers!

Suggested posts