Can't play music imported from Music app

Reply

Can't play music imported from Music app

fletchi
Casual Listener

It started on Monday.

 

I imported a few songs using the Import Your Music feature and as far as I can tell that's when it started (I also updated to iOS 11.2 that day, not sure if that's related).

 

Hardware/Software Configuration

I'm using an iPhone 7 with iOS 11.2 and I've been trying both the Testflight and App Store builds of Spotify (most recent versions as of 6/12 9am CET). I tried playing through the internal speakers, the standard Lightning EarPods, my car stereo via bluetooth and some bluetooth headphones. I can reproduce the issue on all of them.

 

What's Happening?

The symptoms seem to be kinda random, what they all have in common is that at some point the app pauses playback and doesn't continue without user interaction. Sometimes it would play back a second or so. Then it usually ends with either a skip to the next song (where the cycle repeats itself) or it just pause, upon which playback stops and doesn't resume until I push play again.

 

Here's what I tried to fix it

  1. Force quit the Spotify app and retry
  2. Reboot the device
  3. Delete downloads from the music app and re-download
  4. It happens with Testflight and the App Store builds
  5. Delete the app, then re-install
  6. Removed imported playlists using the Spotify app and re-added the music on the iPhone

I think that's as much as I can do. At this point I don't think human error is involved.

SUGGESTED POSTS