Announcements

Help Wizard

Step 1

NEXT STEP

Disable autoplay when connected to Bluetooth

Disable autoplay when connected to Bluetooth

Give an option to not play music when connected to a Bluetooth device like the car. The android client has this why not iphone?

This issue has been brought up in 2018, 2019, and 2020 and the mods keep saying it's a user issue and to reinstall. Please stop lying to us as its a spotify feature issue. 

Reply
29 Replies

didn't work for a minute; rebooted my iphone, and the shortcut DOES seem to work...!

can't edit posts here? anyway, it's just NOT working, it shows up when i connect my headphones (to pause playback on iphone), but... music continues. UGH

This feature still does not exist. All I want is for my music to play when I WANT IT. Not start playing when my car turns on. It is NOT a feature of an older blue tooth, this happens on both car play and the 2022 I just got. I don’t want music to blaring unexpectedly.

 

inreally so like Spotify, I’ve used it for a decade, but “play music only when I want it to” seems fairly simple to expect from a music player. 

I can’t believe I’m saying this but I’m honestly going to look at Apple Music and see if it’s capable of Basic Functionality 

where can I find the feature?

So what I'm seeing on this thread, and several others highlighting this problem is that the only solution is to uninstall Spotify and cancel the sub. Because none of these fixes seem to work, in fact half the menu options mentioned don't exist where they're said to exist. All because i simply don't want to get blasted out of my seat every time my phone connects to the car.

I have the same problem. Even when I don't listen to music and end a phone call, Spotify starts playing music on my Bluetooth device.
I now have the option Spotify Connect on background turned off. Then tested by making a telephone conversation. It now remains silent after the telephone conversation has ended. I turned the option back on. and still remains silent. There may be a bug in this???

Hopefully this is helpful to you. At least it's quiet for me today 🙂

try disabling the option "Spotify Connect", see my post below.

The problem still exists, so this was not the final solution. Strange that turning it on/off seems to work temporarily?

Plan

Premium

Country

Canada

Device

Android, Samsung S10

 

My Question or Issue

Whenever I open spotify on my phone it will automatically start playing if I am connected to my Bluetooth FM transmitter in my car.

I have disabled car mode.

I have disabled Android Auto.

I ha e disabled autoplay.

This problem is not related to any of those things.

It is extremely frustrating.

 

Furthermore, whenever I finish a podcast it will automatically start playing another podcast, but when I open the app it will stop playing and instead list nothing as having been played. This means I have to search for whatever it was playing instead of just having it show up at the bottom of the screen.

Nothing is helping in Android, this a real pain in the... every other media app can do it and dont let startup the app when connected to the car audio.

 

I solved it now this way: remove spotify app an use webplayer in Firefox Android if I want to listen to a podcast. When done, I end the browser and close it, done. It wont appear again till I open the spotify website.

 

Another solution is: logout from Spotify and only login in the APP when really needed. If you save the credentials in your wallet, it works real quick.

Suggested posts