Having trouble seeing your Wrapped stories? To fix this, update the Spotify app to the latest version.

Find more info on our community FAQ.

Explicit Content is not filtered through Siri

Explicit Content is not filtered through Siri






iPhone 8 Plus

Operating System

iOS (14.5.1)

Spotify App Version


My Question or Issue

As a user of Spotify, I have disabled the Spotify setting "Allow Explicit Content" and I am wanting to ensure either clean versions of songs are played or Explicit Content is skipped.


I have also enabled the iOS explicit content restriction through Settings -> Screen Time -> Content & Privacy Restrictions -> Content Restrictions -> Music, Podcasts, News and  Workouts -> Clean .


In reality, if I play a managed Spotify Playlist, i.e. "Hot Hits Australia". This works as expected, Explicit Content is skipped.


If I ask Siri, 'play Hot Hits Australia on Spotify'. Spotify will start playing Explicit Content and this is undesired behavior where Explict Content has been disabled.


1 Reply

I seemed to have fixed my issue by following the clean install steps at:

I will report back if the issue presents itself again.

Suggested posts