Announcements

Having trouble seeing your Wrapped stories? To fix this, update the Spotify app to the latest version.

Find more info on our community FAQ.

Ford Sync streaming Spotify Radio issues

Solved!

Ford Sync streaming Spotify Radio issues

I just recently updated my Ford Sync  to v 3.5.1 bt4t-14d546-ag. This update seems to have fixed the track ID issues that swere common before but I know have a worse problem. It appears that when I am streaming from Spotify radio it will automatically skip to the next song if the buffer gets low. I noticed that certain songs would skip at the same exact time every time they came up to play. This time could be 20 seconds into the song or 2 minutes into the song. So I decided to delete the application because this is the only way I know how to delete the cache and now the majority of the songs will play less than 30 seconds and then skip to the next song. I really enjoy Spotify but the main reason I have it is because I think this is a great alternative to SiriusXM radio. I would appreciate it is some one could take a look at this. 

 

iPhone 4s v 6.0.1

AT&T

Spotify premium 0.5.9.10 settings set to stream at normal setting

Reply

Accepted Solutions
Marked as solution

I just thought I would give an update. I changed the stream and sync levels to high and I also changed turned off the gapless playback. These changes seem to have fixed the issues.

View solution in original post

Marked as solution

Found pretty easy fix to this issue. I was never able to find the solution to play the music from Spotify using USB cable connection with my iPhone and although using some workaround steps the phone managed to play few songs from Spotify without skipping, eventually sooner or later the skipping started again.

I just bought this wireless dongle (link below) and it solved the issue for me. And it only took me 2 years to find that solution :)))

I just tested it in my Ford today, so far it works without any issue, no skipping of songs, able to fully manage the music directly from Spotify on my phone.

Btw, I have Ford Focus 2013 and iPhone 8. Hope it helps and I made your day as I just made mine 🙂

Take care,

Milan

https://www.ebay.com/itm/USB-Wireless-Bluetooth5-0-Stereo-Audio-Music-Speaker-AUX-Receiver-Adapter-D...

View solution in original post

20 Replies
Marked as solution

I just thought I would give an update. I changed the stream and sync levels to high and I also changed turned off the gapless playback. These changes seem to have fixed the issues.

Having the same problem. I'm going to try the solution you posted and see if it works. Thanks for the update

After a couple days with these settings it is much better but it still skips. I really believe that issue has to do with the buffer and cache within Spotify's software but if you look at other threads they say it is not their issue.

That's unfortunate. I have a 2013 ford, so i havent updated the firmware, or spotify for that matter. it worked fine when I first got the vehicle, but just started suddenly skipping a few days ago. I cant fanthom what might have changed to bring about this behavior. I wonder if it will make any difference if you try playing playlists that are saved in "offline mode"

I actually downloaded a couple playlists by WiFi and then turned Spotify to offline mode and played the playlists. As it turns out it does not matter, the tracks continue to skip randomly. I would not recommend updating the iOS Spotify app.

Just Chiming in - same problem here, and the problem is new. It only started when the Spotify App was updated on my iPhone. I have not updated my Sync Firmware.

The problem is definately with Spotify, or at least with their mobile App. It has always had a buffering issue, but that issue never use to force song to completely skip on Ford Sync like it does now. It is almost like it is set on a song preview mode - songs play for about 15-20 seconds and then just skip to the next song.

I'm having the same problem, but it seems to have only started after updating the sync software. I have also tried it wil tracks in offline mode, and it still skips. Will try a USB cable instead of Bluetooth and see if that makes a difference. This really sucks, if I can't figure it out, I will most likely cancel spotify premium since I only really use it in the car.

I started having this same issue about 2 months ago. I'm not sure if it was right after updating the sync software, but it was shortly after. I haven't tried a USB cable yet.

 

T_Go, did you end up trying the USB cable? Did it fix the issue?

I have a 2012 Explorer Limited with all the options. I always keep my Spotify software up-to-date as well as the Ford MyTouch software. The problem is definitely with the Spotify App and not the car. I have tried multiple iPhones and Droids via bluetooth and they all skip to the next song 30 seconds - 2 minutes in.

 

Hooking your phone up via USB will in fact solve the problem. However, this is an annoyance when making short drives around town when you need to take your phone with you!

 

The bluetooth stream worked fine with the previous version of the spotify app but now its back to the same skipping problem. 

 

I have reset the Ford MyTouch system and deleted and re-installed ther spotify app and has made no difference.

Ford MyTouch is already a miserable system and now I can't even listen to Spotify over bluetooth! Anyone in the market for a dark grey 2012 Explorer??

I'm having the same issue with Spotify/Sync. Sometimes it will play a song for over a minute before skipping, sometimes it will play for 5-10 seconds, then other times it will only play for 1 or 2 seconds. On Sync I've turned off auto play, index, and gracenote but that didn't seem to help. I killed three Spotify cached processes on my phone and that didn't help either. The only way to stop the skipping is to restart my phone while it's connected to Sync.

 

I have a Droid Razr Maxx HD (rooted, no rom) and 2012 Ford Edge with MyTouch.

It skips in pandora too so it is probably not spotify. Probably a ford problem

 I have this same issue as well. I have a 2013 ford with sync. I have tried everything that is reccommended as far as trouble shooting. It has to be a problem with spotify. All other media streaming apps work just fine in my car. I have a droid razr and it skips after about 15 seconds. Iphones work just fine when I am playing them in my car using bluetooth. This rules out the possibility that it is sync. My guess is that it is the relationship between the mobile spotify app and microsoft sync. If anyone has had any luck please let me know. Below is everything regarding this issue.

 

Description

 

When I try to play spotify using Bluetooth it constantly skips to the next song until it reaches the end of the playlist or album. It usually plays for about 10 seconds until going to the next track. This occurs when streaming or playing downloaded playlists.

 

What are the steps you took to get to the error/issue?

(We need to know what you are doing so we can do the exact same to try and get the same error)

1. First I tried another Bluetooth device to insure it was not the device. It also skipped to the next song.

2. Then I used a different music player to insure that it was not my phone. All other applications seamed to stream normally.

3. Next I used a different phone on these devices and it worked properly. The phones I used to test were iPhones.

4. Lastly I followed the trouble shooting steps as outlined  in section B of the [Android] Troubleshooting Spotify. This did not resolve my issue.

 

What I expected to happen

I expect to be able to select a song to play and it not skip to the next song after a few seconds. 

 

Did you restart your device when troubleshooting in section B?

Yes 

 

Did you read the connection troubleshooting tips?

Yes 

Your device

Droid Razr

 

Device’s Operating System

Android 4.1.2

 

What type of account do you have?

Premium

 

(FYI for the below points: Android devices tend to refer to the internal memory as "SD Card" and the SD card you inserted yourself as "External SD Card")

Space left on your device

1.62GB

 

Space left on your SD card (if applicable)

14.83GB

 

Space left on your External SD card (if applicable)

N/A 

Is your device rooted?

 No 

Are you using a custom ROM, if so which one, exactly?

No

 

Did you set your external SD card as storage location?

No

 

Did you manually install an older version before installing the latest version from the Play Store?

No

 

Do you have the same issue when switching between WiFi/Mobile Data (If applicable)?

Yes 

If you said "No", when does the issue not occur?

N/A 

My mobile Spotify version

0.6.2.64 

My desktop Spotify version (if applicable)

N/A 

My mobile provider and country

Verizon, US 

My username

Patrik Lemon

 

Do you have a Spotify (non-Facebook) login?

No 

Are you logging in with Facebook or with your Spotify login details?

Facebook login 

Do you have any screenshots you can attach to more clearly explain your issue?

No

I have the same issue:
IPhone4S
2013 F-150 with Sync
Skips to next song - getting worse with time
Replaced head unit in truck - no improvement
Spotify premium
Streaming or offline

I just deleted and reinstalled the Spotify app on my IPhone. First two songs played to the end -that hasn't happened in a while. All playlists and settings were restored when I logged in but having to re-sinc my offline songs, no big deal. I'll post updates on how this works but some of you may want to try this (to increase the sample size).

Thanks for all of the feedback everyone. This is currently being looked into and we hope to have more information soon.

 

So we can narrow down the issue, could I ask everyone who has posted in this thread to confirm that they are connecting to Ford Sync and using Spotify in the way outlined on this webpage?

--------------------------------------------------------------

For Twitter support, find us at @SpotifyCares.

Follow me on Spotify.

Ford has a few versions of SYNC:

SYNC, SYNC with voice navigation and SYNC with MYFORD - these all support applink

SYNC with MYFORDTOUCH does not have applink. This is the system in my vehicle so i can't use the spotify app. I just connect via bluetooth as the "Bluetootth Stereo" input source. This is where i have all the problems with random skipping on songs.

 

The system also has a USB input. I've been using this with my Iphone connector and it works fine - just a bit of a nuisance to plug in every time I get in the vehicle.

I am having the problems described using Spotify with my 2013 Ford with Sync

I am also having this issue. 😞

Not a Ford problem. I have since switched to using Google Music All Access and do not have the same issues with songs skipping like I did with Spotify. This is definately a Spotify issue.

Suggested posts