Help Wizard

Step 1


Local Files Issue


Local Files Issue






iPhone 6s / Desktop

Operating System

(iOS 10, Windows 10


My Question or Issue

Im trying to use the local file function that allows me to add songs from my pc to my spotify playlist for my phone to also download. I got my songs on my playlist already/downloaded and I actually thought they just weren't showing up at all on my mobile but they are there I just had unavabile songs hidden. So they are just greyed out on mobile. Completely functionable on desktop.


1. Yes on the same wifi

2. Both devices are in offline mode, my phone doesn't even wanna download actual songs from spotify that are also in the playlist when im in this function so I dont know why the steps say this.

3. Tried logging in and out / closing and reopening spotify on both devices.

4. I've never been so **bleep** off at something with such simple instructions, im just trying to listen to some bangers from my boy Larry

5. I haven't tried the personal hotspot try yet but I dont really wanna have to call AT&T to activate it, guess it doesn't come with my plan automatically



Accepted Solutions
Marked as solution

Some routers enable them automatically and some don't it depends on your security settings. If you aren't sure, try at a friends or with a hotspot and let me know!

View solution in original post

12 Replies

Hey @larryafisherman, welcome to the Spotify Community!


I've had this issue with local files before as well. Just to confirm, are you using a personal (home) wifi network? Some public networks (at universities, offices, etc.) block peer-to-peer data transfer through various firewalls which makes this kind of local file sync impossible.


Looking forward to your response 🙂

Nope, private connection, pc is connected via Ethernet. Thanks for the response though. And my firewall isn’t blocking it.

Okay, thanks for getting back to me!


A weird thing to try that fixed the issue for me: could you try removing the files from your Local Files in Spotify on the computer, then move the file location to a different folder (doesn't matter where it is, you can make another folder with a different name in the same directory) and then try linking to it again? 

(Also, make sure you're following the steps laid out in the Local Files support article, but it already sounds to me like you're doing that.)

Let me know how it goes!

I started off just using the local files from my downloads, then made a folder on my desktop and put them all in there and added that directory. Then also read somewhere to try making a folder inside your downloads and putting them there and that’s what I got right now. Does that already cover what you suggested?

That does sound about right. Okay, another option is to use internet through your computer's bluetooth. This bypasses the network issue I was talking about earlier: basically what you have to do is turn off your data and wifi on your phone and then connect to your computer's bluetooth. In your computer's settings there is a way to share internet via bluetooth, check out this guide I found online. I'm used to doing it on my Mac but the steps seem fairly similar. While connected via bluetooth, try removing and re-adding the Local Files on your desktop's Spotify.


Try anything you can think of here, this Local File sync can be kinda funky sometimes! Please let me know how it goes and if you make any progress.

Just got back to my pc, attempted what you suggested and I dont believe my pc has bluetooth given it was built by me. I still tried setting my network to sharing like that guide says but my computer still didn't pop up in under bluetooth. Wouldn't really like to buy the stuff to make it that way for this atleast given I shouldn't need it to begin with.

Yeah definitely isn't Bluetooth compatible, doesn't have a on/off switch for it on my desktop



Alright the only other thing I can think to suggest is to try taking a look at your wifi router and completely disabling any port-blocks or firewalls, leaving all peer-to-peer routes open, trying again, and then re-enabling anything you disabled. If that doesn't work or that's not an option, the only other things to try are to use a different wifi network (at a friend's house, for example) or to use a hotspot from your phone.


Please do keep me updated, I hope you're able to get this issue resolved!

Dont really know how to disable/enable port blocks. But I also dont believe they're would be any blocks unless it was automaticly? anyways ill try the other wifi at a buddies house sometime soon and let you know how that goes. Also might contact my provider to see if they will let me enable hotspot.

Marked as solution

Some routers enable them automatically and some don't it depends on your security settings. If you aren't sure, try at a friends or with a hotspot and let me know!

Haha, was so satisfied I finally got to listen to my downloaded songs, got it working yesterday AM by just trying different router. Thanks Jacob!

Glad to hear you got it working! Let me know if there's anything else you need help with 🙂

Suggested posts