Help Wizard

Step 1


Local Files folder not showing

Local Files folder not showing

I have turned on show audio files from this device in settings but the local files folder does not appear. Any idea on what the problem is?




United States


iPhone 14 Plus

Operating System

iOS 16

12 Replies

I had this problem on my iPad. It turned out I also  needed to go into the iPad settings app ( as opposed to the Spotify app settings) and open the Spotify icon there. (The last section of Settings, where the apps are all listed alphabetically)  I had to turn on the button allowing local access there. Then I was finally able to see and access my local files inside the Spotify app.


That option is not available for me.


Actually, that was exactly what I was referring to - enabling the local network and Apple Music. I had those turned off, but when I turned them on, I was able to access my local music that I had downloaded to my iPad and that was stored in the Apple Music app. Were you trying to access local music from Apple or from another source?

What I am attempting to do is play audio files, that I can find in the ‘files’ app, in Spotify.

I’m having the same problem and I’ve tried the same things. Any ideas?

Any updates to this? Having the same issue with an iPhone 14 Pro - can't find the Spotify folder in which to paste my music.


Thank you!

Hey folks,


If you have local files stored on your iPhone, you can add them to your library on Spotify by moving the files to the Spotify folder located in the Files app > On My iPhone. More info here.


In case the Spotify folder doesn't show up in the Files app, try rebooting your phone or logging out from Spotify and signing back in to your account.



Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a "Like".
Are you new to the Community? Take a moment to introduce yourself!

Hi, I signed out and back in and there is still no folder in On My Iphone. Is there another way to do this? I tried a while back with my computer and it didnt work either. All the settings are correct.  Do I have to make the folder myself?

Have been trying to figure this out and just did. If you go into the Files app on your iPhone, then go to the On My iPhone files, create a file called Spotify, and open Spotify and turn on and off the Local Files on the Spotify app. This should fix it and you just have to move your downloaded music to that file.

The fix above worked. For me personally I didnt have to create a new folder, the folder was already created. I pasted a song into there and now its showing on my spotify app. :))

Go to "Your Library" tab, click the profile icon on the top left corner, select "Settings and privacy", Scroll Down and click "Local Files", Enable "Show audio files from this device".


Note: The audio file must be in the spotify folder of your phone. Go to "Files" app, click "Browse" tab in the bottom right, search "Spotify" in the search bar.




United States


(iPhone 11 pro)

Operating System



My Question or Issue

When I turn the Local Files setting on It says it was added to My Library but when I check My Library it isn't there. I also put a song into the folder on my phone to see if it might fix the problem but it doesn't.

Suggested posts