Announcements

Music is not autoplaying

Music is not autoplaying

uyild

Hello Spotify Community 🙂 

 

I've noticed for a month now that Spotify never auto plays when i get automaticly connected to my car, air pods(pressing play). It was like a default where my Music App always went on, but never Spotify. I tried fixing it by deleting the Music App (I've switched recently from Apple Music to Spotify) which i didn't really notice a difference. 

 

Hope you can help me! 🙂

 

By the way, i've a iPhone 11 Pro running on IOS 14.3 & Spotify Premium.

Reply
9 Replies

Ivan

Hey @uyild

 

Help’s here!
 

Start off by running a clean reinstall of Spotify on your iPhone if the Autoplay option doesn't work as expected. This is different than a simple reinstall in terms of removing old corrupted data that could be causing the issue.  

 

In case this persists after the clean reinstall, check if any battery optimization settings or data cleaning apps run active on the mobile device and deactivate them. Such features can often prevent the app from operating at full capacity. We also suggest accessing the app settings and making sure all Permissions are enabled for Spotify. 

 

Keep us posted! We'll be here if you have any questions. 

uyild

Hey! Thanks for your help!

 

unfortunately that didnt work.. it still won‘t autoplay..

Eni

Hey @uyild

 

Thanks for getting back in touch. 

 

Could you let us know if this started happening after a specific event such as an update?

 

On another note, we suggest that you check if there's any pending updates of your device's OS.

 

We'll be waiting for your reply 🙂

 

 

EniModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“Music acts like a magic key, to which the most tightly closed heart opens.”– Maria von Trapp

uyild
Hi! Thanks for the quick response.
To be honest, it never worked. When I used to have Apple Music i had no problems. I stared my car the Bluetooth connection automatically connected and it started playing music, but when I switched to Spotify it suddenly stopped working. With Spotify it never worked. I asked my friends who have a similar car and Spotify, they have no issues. Now I have to go to the Spotify app and actively click a Song/Playlist. Otherwise it won’t work.

Eni

Hi there @uyild

 

Thanks for your quick reply and for the information you sent 🙂 

 

Just to make sure, did you check if there's any pending updates of your device's OS? We recommend using the latest update to ensure optimal performance. 

 

On another note, could you log out > restart your device > log back in?

 

If this doesn't do the trick, could you unpair your device from the car and re-pair it to check if that makes the difference?

 

Let us know how it goes 🙂

EniModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“Music acts like a magic key, to which the most tightly closed heart opens.”– Maria von Trapp

uyild
Just to clarify, i have the latest updates on any devices or Apps. There is literally no difference between my Spotify and my friends. But on their car and Spotify App it works. So weird.

Eni

Hey @uyild

 

Thanks for sending us this info. 

 

In case that you're not using them, could you try uninstalling the other streaming apps (such as Apple Music) on your phone to check if that makes the difference?

 

Keep us in the loop!

EniModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“Music acts like a magic key, to which the most tightly closed heart opens.”– Maria von Trapp

uyild
As I said it before... I‘ve already done that.

Mihail

Hey @uyild,

 

Thanks for your reply and apologies for the confusion.

 

Could you send us screenshots of the Autoplay setting in the mobile app and of the now playing view when connected via Bluetooth? Also, how does the queue look when this behavior comes up- are there any entries there? It would also help us troubleshoot this if you could let us know the exact version of the app you're running. 

 

We'll be on the lookout for your reply! Let us know if you have any questions.

Mihail Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Suggested posts

Env: prod