Announcements

Podcast fast-forwarding causes playback to stop

Podcast fast-forwarding causes playback to stop

 

Plan

Free

Country

USA

 

Device

iPhone 13

Operating System

iOS 16.2

 

My Question or Issue

This issue occurs under very specific circumstances:  you must start playing a podcast whose mid roll ads are served by Spotify (that is, not read as part of the podcast but served as an audio cut out).

 

Many podcasts serve an ad spot towards the beginning of the podcast.  If you fast forward past the point where the cut away ad should pop up, audio playback stops, and the “currently playing” screen with the fast forward buttons closes.  The app does not crash, but playback stops.

 

This can be mitigated if you slide the playback marker manually past the ad break (say, to the middle of the podcast), let the audio play for a second, and then slide back to the beginning.  Now, fast-forwarding past the ad marker triggers the ad as usual (and I can fast forward through the ad as usual also).

 

To repro, try any podcast from The Ringer for the past 6 months.  I’m literally listening to less Spotify-owned content because this has been broken for so long that I now prefer mid roll ads read live by the hosts.  Lol.

 

Reply
14 Replies

Hey @Berger78,

 

Thanks for reaching out and taking the time to describe your issue in detail.

 

We've tested it on our end, however we couldn't reproduce the behavior you've observed. Have you tried any troubleshooting steps like clean reinstalling your app or checking if the same happens with a different connection by a different provider?

 

Keep us posted.

MihailYModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Clean reinstall did not have a lasting effect.  It resumed this behavior after working correctly once.  All of this is over wifi, so "provider" should not be an issue (assuming you mean cell carrier?).

 

I can repro with Friday, 1/20/23 episode of The Ringer NBA Show.  Make sure to hit "15 seconds forward" to advance from the start (0:00) past the ad break at (0:30).  Can I attach screen caps?

The same thing is happening to me, clearly they’re trying to get you to listen to ads and pretend like they don’t know what’s happening. 

Same issue has been happening to me for a couple weeks now.

Didn't see your comment about the Ringer NBA Show before - I'm pretty sure this is ONLY happening to me on Ringer podcasts.

I was just able to make this happen on another podcast where Spotify injects midroll ads.  Monday's episode of La Cabina Telefónica (a random Spotify exclusive podcast I chose) did this when I fast-forwarded past the beginning of an ad break.

 

So, for non-partner podcasts where Spotify doesn't inject ads, I've never seen this.  But I still think that this is probably an issue for all podcasts with midroll ads served by Spotify.  Although, tbh, The Ringer probably accounts for 99% of such podcasts I listen to.

 

@MihailY: Anything to add here?  Seems to be a real problem...

Hi folks,


Thanks for your posts. 

 

Could you provide us with the following info:

 

  • Your device + OS version
  • Current Spotify version
  • Troubleshooting steps you've already tried
  • Does this happen while using a different internet connection?
  • Does this happen with multiple podcasts or only with a specific one?
  • Sending us a screen recording of the issue happening would come in handy. You can attach it by using the Insert Video option in the post editor. You can also upload it to Google Drive and share the link with us (make sure the video has the permissions for anyone to see it).

We'll be waiting for your replies. 

EniModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“Music acts like a magic key, to which the most tightly closed heart opens.”– Maria von Trapp

iOS Version 16.2

 

Spotify Version 8.8.4

 

I can repro with *ANY* podcast with Spotify-served midroll ads at the 0:30 mark.  See attached screen cap.  As you can see I'm on WiFi, connection should not be an issue.  Fast-forwarding past the first midroll ad stops playback.  The only way I can circumvent this is to manually scrub past the ad break, then manually scrub back to 0:00.  Then the ad break fails to play after doing this, but at least it doesn't stop playback.

Looking for an update.  If engineers are working on this, that's fine, but can we at least acknowledge this is an open issue?

Hey @Berger781,

 

Thank you for keeping in contact.


To continue investigating this case, we need to gather as much info as possible so the relevant team could address the issue correctly. Taking this into account, please include in your next response if trying with a different Wi-Fi network makes any difference. If you don't have another one available, you can use a mobile data hotspot to test it on.

 

Also, it would be great if you could include all the troubleshooting you've tried so far to avoid repeating suggestions from our end and to send more accurate info to the relevant team. 


We appreciate your patience and cooperation.

 

We'll be on the lookout.

OscarDCModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

This has happened on multiple different WiFi networks, as well as when I am using mobile data.  I have not found the error to depend on the connection I'm using: it happens on every podcast with a midroll ad at 0:30.

 

I tried doing a clean install, this did not fix the issue.

 

 

 

 

Hey @Berger781,

 

Thanks for getting back to us and for the troubleshooting you've tried so far. 

 

Based on the info you sent us in your previous reply, we've noticed that you're not running the latest version of Spotify. With that being said, we'd recommend checking for a pending update and installing it. You can go to App Store on your iPhone > find Spotify > tap on UPDATE. 

 

Our app is getting better with every update and that should fix the issue for you. It's best if you keep it updated, so you don't miss out on any new features and improvements.

 

In addition, it's also worth checking if your iOS is up to date too. In case it's not - download and install an update for your system too.

 

Let us know how this goes. We'll be on the lookout for your reply and we'll see what we can suggest next.

LyubkaModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.

I just updated to Spotify 8.8.6

 

same problem, no changes.  

Hey @Berger781 ,

 

Thanks for the replies and the troubleshooting tried so far.

 

You mentioned this happens only when trying to skip past an advert at the 0:30 minute mark. Does this experience occur when you're not trying to skip past ads and fast forward a podcast through the podcast content itself?

 

Keep us posted,

 

Cheers!

 

 

DianModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.

Suggested posts