Announcements

Help Wizard

Step 1

NEXT STEP

Spotify Automatically playing in car

Spotify Automatically playing in car

iPhone 12 pro max, IOS 15.5 if it matters. Having a minor irritating issue. When I get in my car, my phone automatically connects to bluetooth in my car. Not sure if that's the phone or the car triggering that. But that's a separate topic. Then, Spotify also automatically starts playing through the car via bluetooth. All the time. On its own. I don't know if this is being caused by Spotify or my car.

 

Is there any setting or explanation why Spotify would automatically self start and play in this way? It's a bit annoying! Thanks for any guidance!

Reply
8 Replies

Hi @seeeker,

 

I am not sure if the following solution will stop your car from connecting to Spotify, but please give this a try and let me know if it fixes your issue:

 

 

  • Make sure you are not using Spotify in any apps like Desktop or Web, then open Spotify on your mobile app, go to  the Settings menu and select ‘Playback.’
  • Toggle ‘Autoplay‘ off "on this device" and "on other devices"

A more detailed article about the above method can be reviewed here.

 

I know for sure that you can turn off "CarPlay" so your phone won't connect to your car, but that will make it so you won't be able to see maps if you're trying to navigate with your phone or use other features for that matter. If you are not concerned about that, you can follow the steps to disable CarPlay here.

 

Reach back out to me if this doesn't fix your issue and I'll see if I can find another solution. 

Thanks!

-jake

 

 

 

 

Hi, thank you but autoplay is already off. I should have mentioned that. The bluetooth automatically connecting is not the main problem (there are other uses when connected), it's that Spotify automatically starts playing. Not even sure how this happens since I only stream on wifi, not data. Maybe the music downloads and buffers for quite a while. Sorry kind of mentioning several peculiarities here, the main issue is the automatic playing. Cheers  

Hi @seeeker,

 

I think this is caused by the device's operating system and how it handles Bluetooth connections. Android Auto has a feature Automatically resume media which users can toggle off in order to prevent this upon connecting to the car with Bluetooth, I'm not sure if iOS has it as well, but it's worth checking the CarPlay settings, as well as the Bluetooth settings on your iPhone to see if you'd be able to find something similar.

 

I also managed to find this iOS user who shares their workaround for this, so feel free check out their post here and test the steps yourself.
 

The Community is always here if something else comes up.

 

Take care!

YordanModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a "Like".
Are you new to the Community? Take a moment to introduce yourself!

For any Android users who are reading this thread, I've seemed to solve the issue with regards to Spotify automatically switching from my home streamer to the car. The solution seems to be in the Permissions of the App itself. Once I toggled off the Permission for Nearby Devices it solved the issue. Bear in mind this is an Android issue and I don't listen to Spotify in the car

I messed with this for months, almost deleting spotify on multiple occasions. I tried every phone system setting, every spotify setting, every quick panel setting, and the mychevrolet app. It turned out to be android auto. There's a setting in there about automatically starting music in a car. Hope that helps!

https://www.hongkiat.com/blog/auto-carplay-spotify/

 

This shows you how to turn off Automation for Carplay for iphones... this is in Settings/Shortcuts > Automation > Car Play

For Android users, it is called "Android Auto".... under settings > connections > Android Auto > start music automatically 

I have the same problem. This is on a 2017 Hyundai Sonata and a Galaxy S22. I have checked, and on the phone, in the Spotify app, Settings, Autoplay is OFF. I'm not sure that refers to the when connecting to car though.

This will also happen with another app called Rocket Player. That stores music on my phone and will play it. That Also will start automatically. This could be a setting on the phone or in the car and not with the apps. 

Has anyone been ablt to fix this? 

Where is "Permission for nearby devices"  ??

Suggested posts