Help Wizard

Step 1


Spotify Connect not working on IOS8 with Argon Inet2+

Spotify Connect not working on IOS8 with Argon Inet2+

Hi all,


I´m having problems getting Spotify Connect to work on my DAB-radio Argon Inet2.


I'm running the Spotify on latest version of IOS8, and latest version of the Spotify-app for IOS8. I¨m also running latest firmware on the Argon radio. My wireless router is Apple Airport Extreme with latest firmware. I know the Iphone and the radio are on the same network, as I can locate and control the radio with an Argon radio app. I can also see the radio as available Spotify music player from the Spotify app for IOS8, when I press the loudspeaker icon.


The problem occurs, when I select the radio as Spotify player from the Spotify app.  Once I've chosen the radio as Spotify player from the Spotify app, the loudspeaker indicates by the moving "soundwaves" that it's getting the radio to take over as music player, but nothing more happens. After 20-30 seconds the "soundwaves" stop moving, and I can repeat the proces to no avail.


Anyone else having problems getting Spotify Connect to work on Argon radios?



13 Replies

I have the exact same problem with almost the same gear (different router). Thought it was a hardware issue at first so I made a complaint at the store and got a new Argon Inet 2+, but the problem persists. I can easily connect the Iphone to the radio via the Argon app, but not with the Spotify app. Or to be more precise, and to my utter annoyance, I manage to connect to the radio with the Spotify app 1 out of every 7 or 8 times I try (and by trying I dont mean pushing a button, but replugging and restarting phone and radio, redownloading the app, etc. Sometimes the app just doesn't detect the radio, even though both the phone and the radio are at full signal strength, other times the radio itself doesnt manage to connect to the network, most annoying however is when the app does manage to find the radio, but is unable to play music on it, even though it says it does. 

The same issue persists on two different Argon Inet's, but at the same time I can easily control Spotify on my Macbook from the Iphone app without a hitch. 

Good to hear that I'm not the only one with this problem. I have the same experience as you. 

I went to the store again today for them to check out my second Argon Inet 2+, which had the exact same issues as the first one. And the store guys got it to work with Spotify smoothly. Thus, so far, I have had two units, both have worked at the store, both have had huge problems working at my place. So this doesn't seem to be a hardware issue. It is either the app or the router. 


These are some notes on what I have tried:



I have tried both a factory reset and the latest upgrade of the Argon unit.

The internet connection is strong, internet radio is working, the only problem is spotify.



I have the latest Spotify app.

A friend of mine tried his Android spotify app, but got the same problem as I do when using my iPhone.

App can control music on my macbook.

The Argon app which controls all functions (FM, DAB, Internett radio, and Spotify) has been working better, but this only means that I get it to connect with the device 2 out of 3 times, and of course the Spotify function still has the same problem on this app. 



The router is in range (a new, well functioning Asus rt-ac66u).

UpNp is enabled by default on my router (this was a suggestion from the store)

Issue persists on both the router's 2.5hz and 5hz wifi connections.

When accessing the router UI on my browser I can click on the Argon unit's IP adress, up comes a "Spotify Information" page with status info. 

- When the unit is turned on, the status info page displays "Logging_In"

- When the unit is turned off, it displays "Logged_In" (YES this is counterintuitive!)

- On the rare occasion that it does work it displays "Connected" (this has happened once). 



I guess I just have to read up on routers. Any suggestions?

I have the same exact same error description. When the Argon unit is turned on, and I enter the units ip address in my router, I see a Spotify status page, where it says "logging_in".


I don't think, it's a router problem, as you have an Asus-router, and I have an Apple router. If we both had Asus-routers, it might be a router issue,

Maybe we can contact Frontier Silicon, who seem to make the network card + firmware in the radio responsible for communicating with Spotify. Perhaps they can contact Spotify developers directly to solve the issue?

Hmm, you might be right that it is not a router issue. But since both of my Argon units have worked at the store (admittedly they only tried it once each time) it seems to me as if the problem is in the router. Or more precisely with the communication between the router and the unit. Now, even if we have two different routers doesnt mean that they could be set up in the same wrong way. There might be a firewall issue, ports could be closed when they should be open, etc. 


Now, I have contacted spotify directly via a contact form and I hope to hear back from them again soon. 

I also found a contact form for frontier silicon, but I havent gotten around to writing them yet:

If Spotify gives you a reply (with or without a solution) please report back. I have a similar problem (though with Denon Heos) and contacted them a month ago, still without a reply.


Thanks in advance, Maarten

I have the exact same problem with Spotify Connect for my Argon iNet3+. 

Router: Apple Airport Express

Phone: iPhone 5, iOS 8.1.3


The Argon app works fine on my iPhone, but the Spotify Connect function suddenly stopped working. Reinstalling the router and the Argon radio has not worked. When trying to connect the Spotify app to the Argon radio, Spotify only shows the icon with sound waves trying to connect. 


It seems that we are a lot of people with the same problem. Has anyone heard from Spotify? What is the solution? 



Hi all!

I have the same problem as you 😞

Argon iNet3+
Asus DSL-N66U
iOS 8

I can't even see the Argon unit in the list of available speakers. Tried the port forward settings provided by Spotify but no luck. I'm a newbie on that sort of stuff though 🙂

If anyone finds a solution, please post it here.

Hi, I have been in touch with spotify regarding this problem and the solution they offered, which worked for me, was to change spotify accounts. The problem apparently is the account, the solution is creating a new account and use that instead. This has now worked for almost two weeks now without a hitch, but there are some drawbacks. You have to get spotify to transfer your playlists from the old to the new account, you also loose all of your followers and the social connections, and you have to delete your old spotify account in order to connect the new one to your facebook account. But at least it solved the problem for me 🙂

That's interesting. Do you know if you had the same Spotify Connect problems at other locations (with other routers)? I have an iPhone with this problem on one location but not on another, so creating a new Spotify account does not seem very logical. However, if you didn't have problems either at other locations, well who cares about logic.


Kind regards, Maarten

I had the same problem with a cabasse stream source.

Problem was fixed after opening the port 4070 on my router.

Have the exact same problem with our Argon inet2+.

We turn the entire thing off, plug out the main chord, plug it in and start again.

it connects now.

I've worked around it it the same way. Still happens a couple of times a
month though.

Suggested posts