Announcements

Help Wizard

Step 1

NEXT STEP

Tracks skipping when connected to Sonos

Tracks skipping when connected to Sonos

Hello, I hope somebody can help.
I've had an issue when connecting to Sonos via the iPad, when I select other devices Spotify jumps to the end of the next track and doesn't play. If I skip to the next track it automatically jumps to the end.
I've uninstalled, reregistered, deleted Spotify and Sonos but it keeps happening. If I attempt to play through Sonos it tells me that it is unable to play - file not found.
I really hope that somebody can help as this is driving me mad now!
Thanks
Reply
13 Replies

I am experiencing the same problem. I have almost no issues with using the Sonos Controller app but when I use the Spotify app (which is the one I prefer to use) I spend ages trying to play something without seeing tracks skipping endlessly.

Never had this issue until a month or so... Spotify, please help!

Same scenario.

Hi, I have the same problem ! thx for help

Updated bothSsonos and Spotify today and its working again! Hope yours are too!

Broken again, so frustrating. 

Same here.

Same problem - any solutions?

I have exactly the same problem. Sometimes it can be fixed when opening both apps, Sonos and Spotify and try to play the songs from Sonos app. Then switch back to Spotify an it works. But ony until the next time you open Spotify... strange...

Same problem here

Solved by switching to Apple Music.

Spotify, is there a reason this is happenng - exactly the same issue. Skips the song saying file not found. 

So I see I'm not alone.  And I also see that Spotify's idea of "support" is to refer the blind to the blind so that we can stumble about together and hope someone chances upon a solution.  So worth paying for.   Controlling Sonos from the Spotify app is utterly useless.  If the songs do not skip continuously, they just don't play.  It should be noted, I can play music using the Spotify app anywhere else, but on Sonos.  Playing Spotify from the Sonos app earns me a "connection to Spotify has been lost" message.  Again, I call BS as I have no problems connecting to Spotify.  So clearly, this is a Sonos issue.  What to do?  As someone suggested, switch to Apple Music.  This is one more Premium subscriber on the way out.

I am having a similar problem. Spotify Premium plays fine using my android device or Windows phone. If I play a playlist using sonos tracks will not finish playing just jump to the next track. This might be after a few 10s seconds or a few minutes. It also happens if I use Spotify Connect to my Sonos system. I have reported the problem to Sonos. Note Amazon music services and TuneIn do not have any problems so it appears to be the Spotify/Sonos integration causing a problem. This was working well for several years.

Suggested posts