Unable to Turn Off Gapless Playback


Unable to Turn Off Gapless Playback


Plan: Premium

Country: USA

Device: iPhone 7 Plus

Operating System: iOS 12.1.4

Spotify Version: 8.4.95


My Question or Issue

Starting about 2 weeks ago, I have been unable to turn off the Gapless Playback function. When I am listening to a playlist, the songs will skip into one another, even when I want to listen to them individually. 


I am able to control the Gapless Playback slider, but even when the slider is turned to "off," the songs will still skip. I have the Crossfade slider turned off as well. Though playing with the Crossfade slider, it seems to be nonfunctional as well, as it has no effect on the playlist.


I don't have this issue when using the Desktop version. When reinstalling the app, it seems like the Gapless Playback slider defaults to "on." Prior to 2 weeks ago, I didn't change any of the setttings, but the songs were playing individually.


Solutions I Have Tried

  • Restarting the device.
  • Reinstalling the app.
  • Signing out everywhere.


Please help! Any suggestions or advice would be greatly appreciated!


2 Replies

Re: Unable to Turn Off Gapless Playback

Casual Listener

I cannot turn off gapless playback on my iPad either.  I cannot say this is a new problem. Let me be clear what I am trying to do: insert gaps / insert silence of a few seconds, regardless of whether silences are included at the ends of the tracks.  


Example album that needs this: Steve Reich - Sextet and Double Sextent.  This contains several distinct pieces, but on Spotify they all run into each other, sometimes with audible clicks. Jarring.


I’m not sure if that is what gapless playback means though...

Re: Unable to Turn Off Gapless Playback


Same here. Spotify seemed to have added the abilty for a playlist to override local crossfade settings, and it's terrible. All we want is the ability to turn it off. The playlists are great, but it makes my ears sad to hear the songs overlap so pooly.