Announcements

Unplayable playlists with cellular data

Unplayable playlists with cellular data

KyleJB

Won't play songs on my playlists while connected to data. They're greyed out. Data is working for everything else. Will work with WiFi.

Deleted app, restarted phone, reset network settings, etc.

 

I downloaded an updated version - the way I got it to play the songs that were greyed out while using data, was by pressing the new 'enhance' button (which adds unwanted songs to the playlist) underneath the playlist name, in the playlist window. Once unclicked, the songs return to being greyed out and unplayable. - iPhone 12 Mini, Spotify version: 8.6.84.1353.

 

Plan

premium duo

Country

Australia

Device

(iPhone 12 mini)

Operating System

14.4.2

 

My Question or Issue

Greyed out playlist songs when connected to data.

Reply
5 Replies

22n7qfly5h3vhdl3ho4l

Mine is doing the exact same thing.

Ever since my eye phone updated it hasn’t worked ever since. 
I have restarted my phone, deleted app and redownloaded! 

I’ve legit tried everything 

Fredd_0_Six

Telstra know about this. I called them and they updated or changed a setting. I think APN issues. I rebooted my iPhone 13 Pro Max and Spotify is back to normal.

KyleJB
I haven’t updated my iPhone yet (I have an update waiting). So this problem appeared out of nowhere for me. Not after updating either the phone or Spotify. It has to be the Spotify software in my case because it temporarily works after various things like clicking the new enhance ‘enhance’ button in the playlist section of the app - but usually stops working soon afterwards.

Fredd_0_Six

I’m led to believe that it had something to do with Telstra’s APN. I can’t confirm this but it’s seems as it’s a Telstra issue? 
Has anyone else has issues with this that’s not connected to the Telstra network?

Last night prior to Telstra doing something there end I was able to access songs that were not greyed out with wifi, with mobile data but while using a VPN and if I hit the random play button in the Spotify app the song playlist would play. I just wasn’t able to play individual songs due to them being greyed out. 

After talking to Telstra this morning they fixed it. They knew something wasn’t right and what ever they did it worked for me. 
I’d suggest that you update your iOS and make sure your using the lasted Spotify app. 
Good Luck 

Kiril

Hi folks,

Thanks for sharing this on the Community!

@KyleJB and @22n7qfly5h3vhdl3ho4l, could we ask you to confirm if you are still experiencing this issue and if yes what are your devices (make, model, OS version) and current Spotify version installed? If you do have updates pending, we strongly recommend to run those and see if this will make any difference. Also can you share the unplayable playlists so we can take a better look at them.

As @Fredd_0_Six mentioned, this could be related to some sort of temporal connectivity issues, or changes done by your local internet service providers. Getting in touch with them might also be worthwhile but in any case make sure your connection is reliable and stable when streaming.
 

Then, it's well worth running a clean reinstall to get rid of any cached files that might be causing any trouble. This reinstall process of the Spotify app one is more thorough than the usual one and contains few extra steps, so please make sure to take them and let us know if this resolves the situation after updating. 

Keep us posted. We'll be keeping an eye out for your replies, thanks!

Kiril Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Suggested posts

Env: prod