Announcements

Help Wizard

Step 1

NEXT STEP

Content not loading over cellular

Content not loading over cellular

 

Plan

Premium

Country

Australia

Device

iPhone 13

Operating System

iOS 15

 

My Question or Issue

Content won’t load when using a cellular connection.

When I open the app the ‘connecting’ status appears at the bottom of the screen (and stays there) but the app never connects.

I have tried deleting and reinstalling the app, updating iOS and restarting the phone, which seems to solve the issue momentarily but then it happens again.

I have tested the cellular connection and it seems to be working perfectly, it is only the Spotify app that is affected.

 

A solution to this would be greatly appreciated as I am currently limited to only using the app when wifi is available.

Reply
41 Replies

Hi I think you should try to reset cellular settings by go to the settings > general > reset > reset network settings 

I’m not sure but maybe it will help you 

Hi, thanks for the suggestion, I have just reset the network settings and it seems to be working at the moment!

Hopefully this has fixed the issue.

Thankyou!

I’m having the exact same issue, I’ve tried factory reset data network however the connection issue comes back after a while. Any suggestions on fixing this?

Unfortunately I’m still having the connection issue after resetting the network settings too


For now, turning airplane mode on and then off again each time I open the app seems to make it work.

Hopefully there is a proper fix for this in the next update.

Hi there!

I know it sounds simple, but it's often overlooked. Could you try restarting your device? If that doesn't help, try a quick clean reinstall of the app. Just follow these steps.

If you're still having trouble, could you let me know the exact version of Spotify and the exact version of the operating system you're running?

I'll see what I can suggest next!

LoxerSpotify Star
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

I'm having all the same issues. So annoying!

Restarting the device helps however after 30min or so Spotify disconnects again. I've tried reinstalling the app, resetting phone network and master restoring my phone but this issue still occurs. not sure if this issue relates to Spotify app or my phone network =/

 

I'm running iOS 15.0.2, Spotify app version is 8.6.72.1273.

 

Same issue here iPhone 13 Spotify issue while using cellular tried reinstalling app, reset network setting etc .. issues comes back after an hour or so.. was using an esim previously replaced it with physical sim same issue.. this  not only affects Spotify but also the App Store.. hopefully we get an update to fix this . This is my first iPhone might go back to android again.. I have iOS 15.2

Hey folks,

Thanks posting here in the Community! 

We've summarized all troubleshooting steps, which have been reported as helpful by other users bellow, for when Spotify can't connect over mobile data:

  1. Toggle Data Saver Mode in the setting menu on/off.
  2. Enable all permissions for the Spotify app. On Android phones this setting is found in Mobile Settings> Apps> Spotify, on iOS devices in Settings> Privacy >Spotify
  3. Try with a different network. For example if you're using 3G, try 4G and the other way around. It's a good idea to also reset your network settings and check if they have any restrictions in place.
  4. Perform a clean reinstall following these steps. Make sure to restart your device after removing the app. This is a simple, but often overlooked step. 

Let us know how you get on.

AlexModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Same issue happening to me too guys, tried the above steps but the issue is still persisting. Recently got a new iPhone 13 pro on the latest iOS 15. I’ve gone to Apple and a Optus about 4 times each, they’ve both performed tests and said it’s most likely Spotify that is causing the issues. I’ve even factory reset my phone and ordered a new sim however it is still happening. Very frustrating…

It’s so very frustrating! I also recently upgraded to an iPhone 13 Pro, had an esim with Optus, thought that it might have been apple or Optus’s problem, but nothing else had problems except Spotify.
In the mean time turning on and off aeroplane mode seems to do the fix, like others have said. Hopefully there’s a permanent fix coming up soon!

Big thanks the the developers for ongoing updates nonetheless.

 

8.6.74.1541

Hey folks,

 

Thanks for your reports.

 

Could you ask a friend/ family member for their SIM card from another service provider and check if you're experiencing the same issue.

 

This will help us look into the matter further.

 

Cheers.

AlexModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Hey everyone, this has been driving me crazy for three days! I’m so happy to see it’s not just me but not too happy about the dates here. Seems this has been ongoing for some time? Is there a fix yet? Please help. Thank you ☺️ 

Hi there @TamaraStevens,

 

Thank you for your reply in this thread.

 

We suggest that you follow the troubleshooting steps that's been provided in the thread to begin with since the solution can be different for the individual.

 

Let us know how it goes 🙂

Take care!

JeremyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Live, love, laugh and listen to music 🙂

Hi All,

Since upgrading to the iPhone 13 Pro Max on Optus, my Spotify has stopped working when using cellular data also. I have two sim cards in my phone, my personal (Optus) sim is an esim and my work sim (Vodafone) is in the physical sim card slot. As soon as I either connect to wifi or switch my cellular data to the work sim card, Spotify starts working again. I have done a network reset and tried the above troubleshooting steps several times to no avail. If it does start working again it is only temporary.

Hey folks,

 

Thanks for the info.

 

Could you please also share with us the following? We'll investigate this further.

  • The Spotify version that is running on your device
  • Device + OS version
  • Your Network provider
  • If the issue persists when you're using WiFi

Keep us posted.

Ver Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

I have the same issue and cannot load content or stream music over cellular. Apple Music DOES work so it would be a shame to have to switch just to have music on my watch. 

WatchOS 8

iPhone OS 15

Have deleted and reinstalled the latest Spotify app several times and in multiple combinations (e.g., just to watch with phone off, to phone then watch, etc...)

The issue seems to also have some interplay with AirPods as the Watch WILL play music back on to my iPhone but not through AirPods. The AirPods are confirmed connected via bluetooth. The Watch symbol in lower right hand corner of the Spotify app is white and flashing. It's like the Watch app is trying to connect to the Watch and can't. AirPods are not displayed as a connection option.

Hope this detail helps Spotify troubleshoot.

 

Spotify version: 8.6.74.1541

OS/Software version: 15.0.2

Network: Optus

Service provider: Optus 47.0

And I would need to test other wifi networks as my wifi is linked to my mobile and seems to make no difference with connectability. Recently turning on and off airplane mode and then turning off wifi is the only way I can get content on Spotify to load.

For additional information I am using a Watch7 and iPhone12

Suggested posts