Help Wizard

Step 1


Why is the search function not working?

Why is the search function not working?

Is Spotify having technical problems? I just began the free trial period, downloaded an update to the app for my iPhone that claimed to fix "pesky" bugs and now the search function just endlessly loops. My only saved track will no longer play. I've already lost a couple of days of use - I'm not inclined to subscribe until I can be confident this system works!
6 Replies

Hey there, welcome to the Community. Can you try restarting your iPhone by holding Home + Lock together for about 10 seconds? If that doesn't help, it's worth doing a reinstall of the app.


For common support questions, see
To judge my musical taste, check out my

Dear community,

I also have the same search problems since yesterday.

When trying to search, the wheel is spinning, to deliver search results, but never deliver search results.

To be more precise, suppose you like to search for an artist...
You type in the name, instead of showing results, the wheel appears and spins.
Clearing the typed in name and restart does not work.

The only solution that works is removing spotify from memory on the iPad.
By pressing two times the home button, remove spotify by clicking the red sign above spotify, and restart spotify.
Even doing this, sometimes search keeps showing spinning wheel a very abnormal long time before working,
The version of spotify before the latest update worked much better.

This is really annoying to do especially when listening to various artists.

I hope someone from spotify can solve this.

I use the latest update from spotify updated yesterday for the iPad 4.

Thanks a lot in advance,


Spotify search has started hanging. I search for a song, and add it to a playlist. This works ok. I then search for another song. The search works, but I can't click on any of the results. I can search for other songs, but I still can't click on the search results. Everything else in spotify works fine.

If I log out and log back in, it works for the first song again.

I've uninstalled and reinstalled spotify but only the first search works (ie. I still can't click on results for the second search).

I'm using an iPad Air. I've had it for 2 weeks and spotify has been working ok.

Any idea what's going on?

More info - There are 2 ways to add to the playlist. Either press and hold on a song to bring up a small album picture. This has a plus sign next to a musical note. The 2nd way is to make the song full screen, then click on the large + icon. The first of these always breaks the search as above. The second way It's clearly a bug. Hopefully spotify will be able to find it and fix it soon!

There's a selection of music bug affecting the iPad, more details here:

Spotify has acknowledged the problem and a fix will be in soon.


Spotify acknowledgement here:

Meet Jeremy! | Day Entrepreneur, Night, Music Fanatic
I'm here to shuffle!

  • Write what matters in your heart to others, you never know whether you have another chance again.

I've seen posts on this since 2012.  


On my iPhone, the Search in the Spotify app hasn't worked in weeks. I've tried EVERYTHING.

-Closed app out several times, logged back in.

-Uninstalled / reinstalled Spotify app

-Tuned iPhone off then on

-Recently I had to wipe my iPhone completely & start fresh due to hardware issues. Didn't restore from backup, started new. From the get-go, Spotify's Seach function isn't working at all.


Search on the go is part of why I have this $120 year subscription! If I want to search, I have to go to my PC to do it, put it in a playlist, & then it shows up.  This is ridiculous. Spotify please fix this!

Suggested posts