Help Wizard

Step 1


auto mix not working if crossfade is enabled

auto mix not working if crossfade is enabled

As of Spotify 8.7.90 on iOS, having “Automix” and “Crossfade” enabled (to 12s) now prevents albums not to Automix anymore.

If I change the Crossfade slider all the way to 0s/ Off, the albums successfully Automix.

In previous versions of Spotify on my iPhone, this was not the case. I was able to have both features enabled without crossfade taking priority on albums (where albums supported Automix)

Device: iPhone14,2 OS 16.2; App: 8.7.90.
Short: it appears crossfading now takes priority over Automix, which essentially disables automix entirely unless crossfade is set to 0s/ Off
1 Reply

Hi @thespaceman9000!


This could be related to the recent changes our teams made regarding Gapless playback. Could you check if you have the Gapless playback feature under the app's Settings > Playback? If not, try logging out by scrolling all the way down > Log out, then log back in to your account - it should show up.


When Gapless playback shows up, ensure it's toggled on and check if the issue still occurs. If it does, it's worth disabling Gapless playback to see if that would do the trick.


In case the issue persists, please share a short screen recording which shows the described behavior in action, so we can get a clear view of what's happening on your end.



Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a "Like".
Are you new to the Community? Take a moment to introduce yourself!

Suggested posts