Announcements

Help Wizard

Step 1

NEXT STEP

Alexa connect issue due to geographical restrictions.

Solved!

Alexa connect issue due to geographical restrictions.

Plan

Family 

Country

Romania

Device

Android

 

 

I Try to connect Alexa with the Spotify account and I get the " You are not eligible to enable this skill due to geographical restriction" I have friends with free pr premium Spotify account in the same city asme who can connect.

I tried changing address on amazon account to Germany and US, beside more apps available, still same restriction available. 

 

There is any option to put a Spotify account on Alexa, the radio stations in Romania are not enjoyable on daily basis.

 

Please save me.

 

thank you

 

 

Reply

Accepted Solutions
Marked as solution

I tried but Spotify was not listed as option for connecting apps...

... so I changed my primary address with US ( it works with Germany also) and Spotify and other music apps appear.... still Alexa was not happy with connection settings..  but after reset on both Alexa device and phone app, they are happy together and I can listen to my favourite music.

 

Thanks for your support

 

Dan

 

View solution in original post

32 Replies

Hey there @dandumitrescu,

 

Thank you for your post here in the Community.

 

Can you confirm if you followed the exact steps that's provided in here

 

It would also be great if you can let us know at which point you see the error message?

 

Also - make sure both your Amazon account and Spotify account are set to the same country.

 

Keep us posted. We're always one reply away 🙂

Cheers!

JeremyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Live, love, laugh and listen to music 🙂
Marked as solution

I tried but Spotify was not listed as option for connecting apps...

... so I changed my primary address with US ( it works with Germany also) and Spotify and other music apps appear.... still Alexa was not happy with connection settings..  but after reset on both Alexa device and phone app, they are happy together and I can listen to my favourite music.

 

Thanks for your support

 

Dan

 

Hey @dandumitrescu,


Thank you for your reply and for updating us.

 

We're really glad to hear that everything works as it should for you again 🙂

 

If anything comes up we're always happy to help!

 

Have a great Saturday 🙂 

 

Cheers!

JeremyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Live, love, laugh and listen to music 🙂

Hello, Dan! I have the same exact problem as you , but unfortunatelly I did not managed to solve it. I have chanhed my amazon account to Germany amd also the adress on Alexa App. However the same geographical restriction message appears. I am going crazy plz help! I am also from Romania, I use and echo dot 4.

Hey there @Cristinaspataru,

 

Thanks for reaching out to the Community and welcome.

 

Keep in mind that the Alexa integration isn't available in all markets. In this case, we recommend to reach out to Amazon Support for further assistance on this matter.

 

If you have any questions or need a hand with anything else, give us a shout.

 

Cheers!

CarlosEModerator
 
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 

Hi there Cristinaspataru,

 

The geographical restriction is app version-related. 

 

To solve this you need to have an android phone. Download and install the old version of Alexa app without the restriction, I went down up to 2018 version, you can download from this link - https://apk.gold/download?file_id=942356/amazon-alexa

 

After installing the old version, login with your Alexa account then proceeds to add Spotify in Skills then link your Spotify account. There will be no restriction (no need to change your country or location)

 

After enabling, logout from Alexa app then uninstall.

 

After uninstalling the old version, you can now install the latest and log in with same Alexa account (this time either iOS or Android). You will see that Spotify skill will still be there enabled with no issue.

 

 

Spent 30mins with Amazon customer care and finally what solved the issue for me was to add the skill from within the Spotify app, as opposed to from the Alexa app.

Open Spotify iOS app, go to Settings, choose "Voice assistant", then select "Link Alexa". Worked like a charm for me!

 

After doing this, the error message "You are not eligible to enable this skill due to geographical restrictions" disappeared also from the skill page in the Alexa app.

Holy *%#^!

This just saved my Dots life since I was just about to smash it to small pieces, thanks!!!

Neither of these solutions worked for me. In the end, I had to change my country of my amazon account and everything worked just fine. 

LIFE SAVER!!!

Whoa, this worked for me! Thank you @lucagibelli

 


@lucagibelli wrote:

Spent 30mins with Amazon customer care and finally what solved the issue for me was to add the skill from within the Spotify app, as opposed to from the Alexa app.

Open Spotify iOS app, go to Settings, choose "Voice assistant", then select "Link Alexa". Worked like a charm for me!

 

After doing this, the error message "You are not eligible to enable this skill due to geographical restrictions" disappeared also from the skill page in the Alexa app.




I tried, that, it didn't work for me 😞

where did you change your address? I have the same problem

update - I tried all of the above solutions with no success - until I went into the "apps" section in my spotify account, removed the access granted to alexa, then I was able in the spotify app to re-enable the access, and now it works. 

sympathise with the pain and suffering of other's experience 🙂

What worked for me was downloading VPN and mock location app. I logged out of everything, changed my location to US, logged back in, and it finally worked!! I was getting so frustrated already. 

 

Hello.

I have same issue here, but previously It worked fine.

So, will I have to install old version of Alexa to My Android and then set It up?

I have this problem from yesterday and I don't know, what to do. Also, I have previously disabled this skill due to some Spotify issues.

So, how to fix It? I am from Slovakia and previously I haven't such issues.

Hey @Noguri,

 

Thanks for your reply in this thread 🙂
 

You can start removing the access you've granted Alexa in the Apps section on your Account page. Then, if you see Spotify on the Alexa app, you can unlink them following these steps.

 

You can use that last one link to sync Spotify with Alexa. If that doesn't do the trick, try reinstalling both apps. You can find the steps to do it here.

 

Keep us in the loop and don't hesitate to get back to us if you have any other questions. 

CarlosEModerator
 
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 

I have tried bot things, but nothing happened. Problem is still there.

It is maybe, because of geographical restrictions, but previously It
wasn't in Slovakia.


I have tried those steps previously, but It didn't help.

I have also tried to get to another device, so I haven't now problem with My Google Nest. I'll try to look on It as soon as possible, but maybe I'll have to change My country for example to United states.

Suggested posts