Help Wizard

Step 1



Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...


Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...


Can't create account; sign up page continuously loading after pressing sign up

Can't create account; sign up page continuously loading after pressing sign up

Made an account while i was in austria, can't use it anymore in croatia, tried creating a new one.


The title says it all, i go to sign up, i fill it all in, solve the chapta, click sign up, and then starts the never ending loading. No error message, nothing, just an ever spinning circle of loading.

22 Replies

Apparently posting on here fixed it by itself, how miraculous.

I'm getting the same message over and over again. I still can't sign up. Hope you got sorted 

I'm also having this problem. When I try to sign up, the page keeps loading, until eventually the verification expires - yet it continues to load.

17-09-2017 15-07-34.png

just tested it - I can confirm the issue!


OK seems I found the issue...

when you click on "signup" from the webplayer login, there's a param added to the URL - this param seems to cause the infinite "spinning wheel of death"...


Remove the highlighted part from the URL and open the URL (then u get to a general signup, without that forwarding). From there creation works as usual - but you have to manually go to the webplayer afterwards!


Not the issue for me. I went directly to and tried to sign up (have been trying for almost 2 weeks actually). The issue I am having is the stupid reCAPTCHA verification is expiring... every time!


Spotify is loosing money over this I'm sure. People cannot sign up.


same problem! tried every device and browser, incognito mode, clearing history, no chance. 

Is someone listening? 

I am, but I'm only another user suffering from this,  just like you. I pinged @SpotifyCares on Twitter too, and I suggest anyone else with this problem and a Twitter account do the same: the more voices we raise on this, the better chance we have of a fix.

I'm also having the same issue. Tried different browsers, incognito/private mode and still nothing

I have the same problem. Just signed a family account and try to add my son but to no avail, the signup just keeps trying until the verification ends. Tried it 20 times now.

I tried to sign up for 2 months and had the same problem with the spinning wheel. Today i decided to use another browser and switched on the VPN. Luckily i managed to sign up:) Hope it helps you

I am having the same issue, trying to register a new family member. Tried on 2 different browsers.

Anyone has a solution?

Same problem tonight, have just gone to a Family subscription and couldn't add one family member because they can't register for an account on the PC. Failed with both Firefox and Edge on Windows 10 on two different computers. Tried on Android phone with same result.

FOUND IT- - vpn works as this website only works for us citizens;/

Great news 🙂 what do you mean by 'us citizens'? Where is that? 😉

(-____-)...... I smell sarcasm....

and u forgot to touch the like button 😛

VPN from the US is also not working... The only option, Facebook???

Had the same problem, you need to dowload a program called "TunnelBear" ( and trick it to be in anouther country like US for example, although Germany will give best internet speed but don't put it if you don't know German. When you do that turn TunnelBear of since you have 500MBs a month or (1GB extra if you tweet about it) and those 500MBs are more then enough to trick your internet connection or websites that don't comply because of what coutry you're in here and there. Hope this helps and that I'm not late! Have a nice day!

Suggested posts