Announcements

Help Wizard

Step 1

NEXT STEP

Android TV - External Keyboards Not Working Since GUI Update

Android TV - External Keyboards Not Working Since GUI Update

Plan: Premium

Country: UK

Device: Sony XF90 Android TV

 

My Question or Issue

 

Hi Spotify Community,

 

For the last 18 months I've been using the Spotify Android TV App on my Sony TV, in combination with an external wireless keyboard connected to the TV's USB port. This has served as a great solution for typing in track names, avoiding cumbersome entry with the TV remote. 

 

Within the last week my keyboard functionality has stopped working correctly - it seems to align with the recent GUI change (new sidebar etc.). I have updated the app to the very latest version (1.30), along with my TV firmware, but to no avail.

 

I am unable to enter text in the search box, and instead certain key presses have bizarre outcomes (e.g. caps lock causes the page to scroll down). Arrow key functionality does appear to work correctly for navigating the GUI. To confirm, I have checked the cursor is definitely "clicked" in the search box.

 

The results are the same across 3 different keyboards, 2 with a wireless dongle and 1 via Bluetooth. Text input on other applications, such as YouTube, is working fine - same as ever.

 

Any support would be much appreciated.

 

Thanks,

James

Reply
77 Replies

Still nothing? Is this not solvable? 

Hi there folks,

 

Thank you for your posts and feedback in this thread here in the Community.

 

We're always testing things by adding or removing features to make Spotify better overall and we’re constantly aiming to improve our features. However - we can't say when and if there will be a fix for this.

 

You can read more about how your feedback reaches Spotify here.

 

Once again - thanks for the feedback, we appreciate it. Let us know if we can help you with anything else. 

 

Take care!

JeremyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Live, love, laugh and listen to music 🙂

Sorry, but this is a BS, stock answer that doesn't address this particular issue in any way.

@Jeremy: Can you please, in your own words for everyone who has reported this issue in the past year and so, summarise it in a couple of sentences so that we know you have both read and understood it.

It's definitely how Spotify search works with any USB keyboard. Not just logitech apparently. Shocking how there's still no solution to this. 

The app just got updated to version 1.48.0 and still no fix for this issue. I'm starting to think the UI has been put together in such a haphazard and ham-fisted way that they are unable to fix this without a major overhaul. Something they seem unwilling to do (or even admit).

 

The Windows UI gets updated at the blink of an eye, but Spotify seems to regard us Android TV users as something hardly worth mentioning.

Today I realised it's possible to write accented words and accent marks. The input is there.

Back in April, I noticed that holding down the "Enter" or "Return" key (NOT the "Shift" key), allows you to type in the search box normally. Although nobody seems to have confirmed this, maybe this hack only works for me or nobody understood what I meant... I've been using this ever since with success.
I doubt that this issue is even on a backlog of bugs to fix, or that any development time is allocated to do bug fixes at all, so I'm not holding my breath for a real solution.

Hi Marqiss,

 

I tried your suggestion back in March but it didn't work for my setup - I've tried again on the latest version of the app but with no luck.

 

To confirm, I've tried both:

- "Clicking" in the search box with the TV remote, so the cursor is blinking, then holding Enter while typing on my USB keyboard

- Selecting the search box on screen, but not "clicking in it" (i.e. no cursor blinking), then holding Enter while typing on the keyboard.

 

Incidentally, what region settings do you have set for the keyboard? The recent comment from Huothar about accented words working is interesting.

 

In any case, thank-you for the suggestion - hopefully it will help some users.

 

My setup:

Sony XF90 Android TV

Generic USB keyboard attached to USB port (multiple other keyboards tried).

Latest version of Spotify Android TV app (and all versions since May 2020).

 

Cheers,

James

Today I disabled both the external keyboard and gboard. Google voice input pops up (and I can’t seem to get rid of it after that) but the external keyboard input works. 

 

image.jpg


When no virtual keyboards are detected, google voice sets as default (and option switch greyed out). I also disabled Google for the voice app not to pop up and effectively did not pop, but the external keyboard could not be used.


The only way I could type in was with the google voice control activated and annoyingly taking an important part of the screen.

 

I also tried removing Google permissions for mic, uninstalling updates and disabling Google voice services. No good results. 

It seems it could be a problem of the Spotify app and gboard. This problem is also shared by HBO Max apparently. 

btw, new update 1.49.0 still uneventful.

It's been almost 1.5 years since this thread was opened and a year since Spotify answered with the following:

"There seems to bee a synch issue related to specific set-ups with Spotify on a smart tv and an external keyboard. We've reported this to our developer team and they are currently working on a solution. We recommend keeping an eye out for future updates to the app, but can't set a specific timeframe for when this issue will be fixed."

 

Since I first encountered this issue with my Shield the app has been updated from version 1.33.0 to the current 1.49.0. In any self-respecting software house leaving a bug like this unfixed for more than a year after the root cause was discovered would be unthinkable.

Maybe we could ask Adele to have Spotify react to this issue in a timely manner...

I've got the same problem with a new Chiq TV. Why is it taking so long?

Today I'm really annoyed by this bug. I could live with a workaround of using Chromecast every now and then to search and play music until they changed the suggestions into a bunch of mix-playlists and podcasts.

 

I mostly listen to albums by artists because I like a certain Artist. If I want a potpourri of music I listen to the radio. 

 

Fix the search function! Or does anybody have suggestions for an alternative to spotify? I know a Dutch company that lost a lot of customers because the couldn't fix their app, while customers made very clear what they needed. 

 

Workaround: I replaced Gboard with the app LeanKey Keyboard. Works fine with Spotify. I recommend you guys do the same. 

Almost two years and still no real solution.

 

The LeanKey app gives a disturbing warning about sending what you type. Viewing the pic with the Russian alphabet made me uninstall it immediately.

 

But I may have found my solution. Testing another streaming app and the keyboard works. I got 3 months free so if it's as good as Spotify I'll make the switch. 

 

PS It only took me an hour to decide. Bye Bye Spotify, I stopped my premium acount.

Precaution is always a good idea. Hence the warning (that I took as generic and probably applied by google for any third party keyboard). I’ve chosen to trust the developer and the google play verification. It’s not ideal and not a solution either, that’s true. Certainly I won’t be typing sensible info, but I’m okay with the results it has given me.

You're right about the likelihood of typing sensible info on your TV-set, but I don't trust playprotect and for good reasons.
https://finbold.com/androids-google-play-protect-ranks-last-in-detecting-spyware-at-31/

If I don't really have to install a sketchy app I won't.

Having this problem - two years after this was initially reported (on nvidia shield TV) - app and OS are latest versions, cache was cleared 

This issue was originally reported almost FIVE YEARS ago. One of my earlier messages links to another thread from April 2017.

I have removed the spotify app, restarted my TV, and reinstalled the Spotify app.

This has made no difference.

 

The search function on Spotify recognises my wireless keyboard as once it is connected remote control input is disabled.

The only response the keyboard gets from the search bar is when I press enter, the cursor appears in the search bar, but that is all, no other key presses are recognised.

 

This is not an issue with my TV or the keyboard as it has worked without issue with the YouTube app ever since I got the keyboard.

 

This thread is at least 2 years old and still this is an issue, not impressed.

Suggested posts