Help Wizard

Step 1



Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...


Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...


Bluetooth headset play/pause buttons doesn't work

Bluetooth headset play/pause buttons doesn't work

I have a new Jaybird Wireless bluetooth headset paired with an Android Nexus 6 phone. When using the remote control on the headset only vol up/down works. Play/pause does not work! Really annoying. Most of other media apps I got doesn't have this problem. What is wrong with Spotify? Even when I receive a call and answers it via the headset remote the call will be connected but Spotify keeps playing too. So I have to unlock my phone, go to the Spotify app and press pause on the Android phone. 

(Spotify version armV7)

18 Replies

I'm getting this exact same issue. If your issue is like mine, I've found that the spotify notification disappears from the top. I expect the pause works through access to the notification. If I close the app and restart it, the notification appears again and all pause functions work fine. But after twenty minutes or so of listening, the notification has disappeared, and pause (through headphones, widget, receiving phone calls) stops working. Completely baffled. I have restrated the phone. I have tried giving the app priority notifications, I have made sure Greenify is not killing the app, I've made sure Spotify has Contacts, Storage and Telephone permissions in the application manager. Not sure what else I can do.

I gave up on Spotify due to this issue and started using Google Play Music instead. That worked perfectly fine with no issues at all so there is nothing wrong with my gear. Next day I accidentally opened Spotify and noticed that it actually worked too! After 2-3h it stopped 😞  Same thing as before. They must do something totally wrong since all of the other music players I've tested is working as expected.
So you're probably right FolkTalisin, killing the Spotify app and reopen it may work for an hour or two.

Erh, yes I'm have two accounts. tonyal and ekafallet both belongs to me 🙂

Now it's working. I had the issue for two days. The 3rd day it worked!?. I've not noticed the play/pause issue since then and have been able to use the app for more than a week now. There is always a glitch when sending pause and play command the first time after Spotify app startup.and/or headphones startup. The app doesn't get the commands or is doing a double-command.


Has been testing both PC app and Android app with positive results.
Getting "This song is not available" if I pause, turn off the head phones and the wait for half an hour or so. Have to close and restart app to unlock that issue.
Same thing with the PC application. But that one is a lot harder to "reset" if you have connected your PC app to the Android app. You have to:
1. close the PC app
2. close the Android app if opened
3. start the Android app (now it's working on Android)
4. start the PC application. (now it's working on PC)


Generally the PC-to-Android connection is troublesome.

I'm sorry but this isn't exactly a solution is it. I don't know who marked this as a solution but having to restart the app/headset every 15 min does not qualify as that. If anyone from Spotify is listening please fix this. Extremely frustrating when none of my headsets can pause the effin music. And no its not my device, no its not the headset. It's this app. 

Why is this marked as a solution? It still doesnt work! I'm having the same problem with several bluetooth headsets. After some time the play/pause functionality stops working. It starts working again if I restart the phone/spotify app.


We need a solution to this asap!

Just bought the Jaybird Run headphones. Had the same issue with the Play/Pause feature not working when connected to my iPhone X. I was able to get the feature to work by closing other open apps. I’m no expert on Bluetooth connectivity but I assume the headphones may have been confused with an open YouTube window or perhaps a video player in my web browser and not know which service to “Play/Pause” when the button was pushed (even though Spotify is clearly the active music source). Try closing other other open apps and see if that solves it. 

I always have the other apps closed, no use sadly.

I Just got the sony headphones they are great but I have the same issues ... I cant change the track on spotify??? can anyone help `

I have the same problem with my jbl headphones

Got beats studio 3s, worked fine for a week or so but today noticed its not working. Will this fix itself? 

same problem. ill start up a playlist on my galaxy s7 edge which is connected to my LG active and my android wear 2.0 watch. sometimes I can skip tracks sometimes I cant. but I would say about 90% of the time I cannot pause/play on either Bluetooth device. I have force stopped it, clear data, and even reinstalling the app but no luck. this is an infuriating problem as I now have to pull my phone out of my pocket or backpack just to pause the music. spotify please fix this asap.

Same problem here. Tested with multiple headsets (cable and bt) problem still exists. Other Apps wotking normaly


Device: Galaxy S8

Same **bleep** with my Skullcandys. Haven't been working for 3 days now... Idk why this thread hasn't been solved yet. Good job Spotify.

I started force closing the app and that sometimes helps for like 4 songs. After that it's back to not working.

I have the exact same issue whit my Jaybird X3, the play pause combination doesn't work whit the Spotify app, some time it works again when I close the app, but most time don't.

worked for me indeed (I have the Jaybird Run earphones).


The solution is to
clear the cache and data of the Spotify app:


Step 1. From a Home screen, touch and swipe up or down to display all apps.

Step 2. Tap on Settings.

Step 3. Tap on Apps.

Step 4. Scroll down and tap Spotify app.

Step 5. Tap Storage.

Step 6. Tap Clear cache.

Step 7. Tap Clear data.



Step 1. From the Home screen, swipe up to display all apps.

Step 2. Tap on Settings

Step 3. Tap on Apps

Step 4. Tap Menu

Step 5. Tap Reset app preferences ,then follow the prompt to proceed with the reset

Most Importantly, To clear the cache and data of the Bluetooth app:

Step 1. From a Home screen, touch and swipe up or down to display all apps.

Step 2. Tap on Settings.

Step 3. Tap on Apps.

Step 4. Tap on Show system apps.

Step 5. Scroll down and tap Bluetooth app.

Step 6. Tap Storage.

Step 7. Tap Clear cache.

Step 8. Tap Clear data.


I've had that problem for over 6 months, until today I just got off a live chat with Samsung agent. I have a galaxy note 5, I believe this is a Samsung issue. But that should fix your problem. The last step should be the fix, but try all to be sure! Good Luck!

Suggested posts