Help Wizard

Step 1

NEXT STEP

FAQs

Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...

VIEW ALL

Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...

VIEW ALL

Can't use Bluetooth controls after last update

Solved!

Can't use Bluetooth controls after last update

nourchicago

I use Spotify in my car all the time. As a premium subscriber I am very disapointed after the last update. The bluetooth controls won't work anymore (can't scroll/skip songs). The worst part is that if I receive a phone call, Spotify will still run in the back during the phone call making almost impossible to have a decent conversation. I have to open the app on my phone to manually hit "pause" button in order to have a proper phone conversation. All this while I am driving, distracting my attention, not safe. Because of this issue I had to stop using Spotify in my car. Also, can't skip songs on my phone lock screen. Please fix this problem before I cancel my subscription! 

Reply

Accepted Solutions
Marked as solution

0405249080

I have had this 6.9 since it was automatically updated couple(?) days ago. Generally it has fixed all the problems I have had with the Bad version. Only once it have not stopped playback when losing BT connection (switching off car), but that was only ramdom case, typically it have worked well with this 6.9. All BT-controls works fine, lockcreen behaviour is as it should. The only minor flaw what I have noticed is the swipedown spotify application area is quite tall. While other messages as email notifications are as they should. But I think this same is with all other playback apps.

-cahtty-

View solution in original post

26 Replies

Envoy7
Hi
I literally just solved this issue for me. I went into settings -> apps -> permissions.
Unchecked everything and then rechecked them again.
Exited out and everything was working again.

Cheers!

evo4g63t
Interestingly enough I did this permission check and found they were set to disabled, for some reason it would seem Spotify gets its permissions disabled on the latest update.
I re-enabled the permissions and not only did bluetooth function again Spotify shows up on the lock screen again.
Thanks man you have no idea how frustrating this has been for me the past two weeks, I was literally two days away from cancelling since Spotify themselves can't offer any solutions other than delete everything and reinstall (which didn't work).
I've shared this suggestion with the people with the lock screen issue I hope you don't mind.

Envoy7
No worries buddy. I had the same problem myself so I just started trying random things.

No problem at all. Hopefully everyone who has this issue sees the fix (:

Have a good one!

evo4g63t
Much like other solutions here they work but only for a limited time. It worked for about 10 minutes and going to permissions this second time showed them all still enabled I guess I spoke too soon.
What does seem to work for both the lockscreen problems and Bluetooth control is to downgrade to 6.2; instructions below:
Please note you will likely have to redownload your music, so do this when you can download again.
- uninstall Spotify
- make sure auto update in playstore is disabled or it'll automatically update you back to 6.3
- enable the ability to install apps outside of the playstore (I suggest disabling this setting once you've installed 6.2)
- go to http://www.apkmirror.com/apk/spotify-ltd/spotify/spotify-6-2-0-1028-release/
- download the apk for ARM architecture and install it

nourchicago

I tried something else, really easy and it worked. So far seems that the problem is solved. Simply take the battery and the SIM card out for about 15 seconds, put them back and start you phone back on. Give it a few minutes after that and try Spotify. Let me know if this worked for you. 

evo4g63t
I switch batteries all the time and naturally it works but it only works for a short period then it glitches out again, as far as I am concerned this is on their development team and doesn't have anything to do with settings or Android. The only solution that had worked for me is downgrading 6.2

FerroGiconi
I really hope this works, I just started using Spotify after using Pandora for a couple years and I really like it a lot better except that I've been unable to use track controls over bluetooth like I could with Pandora. It never asked me to enable any permissions, and it turns out they were all disabled by default.
If not, when my free month runs out I'm probably going back to Pandora because it's a lot safer than looking at my phone every 10-15 minutes while driving if I want to skip a track.

Guess I'll find out in the morning on my way to work.

[EDIT]
This fix did not work for long. I was able to use bluetooth track controls in the morning after giving it the permissions but later that day on my way home it wasn't working again.

Downgrading to 6.2 seems to have worked for me. It worked on my way to work and 8 hours later on my way home without me having to reset the permissions again. I'll stick with this version for a little while and hopefully I can update again soon.

sparkie5000

I am experiencing something very similiar. If the phone screen isn't turned off, on the lock screen or the spotify app is in the forground the next/previous songs don't work. This is extremely frustrating, especially if I am trying to use google maps to go somewhere and want to glance at my directions AND change my music, god forbid. I've been searching for ages for a solution but to no avail. I have a mazda 3 if that helps at all. Any suggestions/updates/bugs to look at would be incredibly helpful. Thanks in advance!

epicaricacy

I had to "Force Stop" Spotify for the permission changes to get picked up, but this otherwise worked for me. Thanks!

 

Edit: Latest update (6.5.0.1816) fixes the problem!

Edit #2: Stopped working again after a few days :(.

evo4g63t
No 6.5 does not it'll start doing it again just give it time. I am convinced these android programmers have no clue what they are doing, the only difference I see from 6.3 is a version change there isn't anything I can see that has changed all the same bugs are still there.
The solution for now is to downgrade to 6.2 or lower.

I'm having the same issues since the last update, mine is a sony bluetooth car radio and the controlls no longer work with spotify, I also can't get song info, makes me upset i came back to spotify premium to only find it broken

Tiralus

Wanted to chime in that 6.5/permissions changes have done nothing. I have a Samsung Galaxy S7 Edge. Downgrading back to 6.2 things are working again. Bluetooth controls work if you kill spotify and start it but if you leave spotify up and reconnect then it bugs out again. 

Reldey

I am also having this issue, as is everyone else I know that uses spotify regularly on android. It is super annoying, and dangerous while driving. I have tried everything except downgrade, and then I will just have to manually update all my other apps. Looking for a real software update solution on this.

BlueShell
This needs to be fixed asap. It's driving me crazy and now I can't listen to my music in the car because it's not safe! I don't want to cancel my subscription and use Google play music until this is fixed but I can't handle not having ondemand music in the car.

nexus490

I have the same problem on the Samsung S7, have downgraded spotify until this is resolved.

Poundcake

Same Problem on an LG V20 running Android 7.0. Downgraded and controls work now but my display in car is ALWAYS one song behind. Weird 

evo4g63t
It's been over a month and they still haven't acknowledged these problems or even bothered to notify us that they are working on it.
It's unfortunate that I've invested such time on my playlists or I would have switched already. This is really getting ridiculous.

Reldey
Can anyone confirm if the new version fixes this?

evo4g63t
Ditto, would also like to know if the November 9th update fixes this.

Please before confirming it works play with it for about 20 minutes or so, 6.5 "fixed" it for about 10 minutes then it went back to doing the same thing it always does.

I foolishly updated to 6.5 thinking it was fixed but it wasn't so I am going to wait this time for someone else to be the test subject.

Suggested posts