Help Wizard

Step 1


Clock app keeps disconnecting

Clock app keeps disconnecting






Asus Zenfone Max Pro M2

Operating System

Android 9


My Question or Issue

When trying to use the Clock app to set Spotify as an alarm, the playlists list keeps "refreshing", making it impossible to search for songs or playlists to add as alarm.
Whenever it refreshes, I noticed the notification in the upper drawer keeps changing between "The app Clock is connecting" and "The app Clock is connected".
Both apps are in the latest version (6.2.1 for the clock, 8.5.44 for Spotify). I also tried downgrading the Clock app to the previous version (6.1.1), to no avail.

So far, for troubleshooting I tried:
 - soft rebooting the phone
 - clearing the cache of Spotify, uninstalling, rebooting the phone and installing everything again
 - clearing the cache of the Clock app
 - turning off Spotify's notifications
 - making both apps "non monitored" by the battery app
 - doing the connection with bluetooth on and off
 - deleting the app connection from my account in Spotify Web and creating it again
 - trying to set Spotify as my alarm while using both wireless and 4G

3 Replies

I have the same, but with a slightly different setup:

Plan: Premium Family

Country: Netherlands

Phone: OnePlus 3T 64GB/6GB

OS: Android 9


Google Clock: latest version


How to reproduce:

1. Open Google Clock

2. Click the (+) button in the Alarm tab. A time selector is displayed. Click OK.

3. A new alarm is listed and expanded. Click the bell icon. A new window is opened containing generic playlists. Click the Spotify tab.

4. Click the search icon. A window opens and closes. This window should contain my recent playlists but it doesn't.

5. Type anything in the search bar. If you get to finish your search string, nothing is displayed. But most of the time you are thrown back in the generic playlist.


Expected behaviour:

I can select from a personalized history of playlists or search another


Actual behaviour:

I can only choose from a very limited generic list of playlists


Can confirm this issue, replicated on a Moto G8 Plus (XT2019-1, Android 9).


Only generic playlist options appear. If I try to search, I will usually only be able to enter three or four characters before the search results disappear and I'm back on the generic playlist screen.


In the notification area I can see a "spotify connections" entry with the subtext "clock is connecting", which after a few seconds changes to "clock is connected". This notification appears repeatedly as I try to use the Spotify feature in Google Clock.


Sometimes, if you're really lucky, the last played playlist shows up above the generic playlists.


Sadly, even if you do get to pick the last played playlist, Google Clock will only ever play the first song in the playlist. It will never shuffle.

Things I've tried so far:

- Restarted the phone

- Closed both apps and restarted them

- Reinstalled Google Clock from factory default

- Reinstalled Spotify

- Disabled "Adaptive Battery" globally (it was the only battery-related optimization feature that was turned on)

- Played the desired playlist on Spotify *while* attempting to choose the playlist from Clock (result: Spotify crashed)


Can this thread be merged with this one? They seem to cover the same symptoms with the same version of Spotify.

Suggested posts